summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm900
1 files changed, 900 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5bd5c60d49..eac6293fc9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,9 +59,11 @@
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages networking)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages statistics)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
@@ -10839,3 +10842,900 @@ using @code{S3}.")
for model selection. The calibration methods available are based on the slope
heuristics.")
(license license:gpl2+)))
+
+(define-public r-dorng
+ (package
+ (name "r-dorng")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "doRNG" version))
+ (sha256
+ (base32
+ "1sb75aqkliprglfxc4x4wds6alqgzhvl2n812g1d32a88ra3slr7"))))
+ (properties `((upstream-name . "doRNG")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-foreach" ,r-foreach)
+ ("r-iterators" ,r-iterators)
+ ("r-pkgmaker" ,r-pkgmaker)
+ ("r-rngtools" ,r-rngtools)))
+ (home-page "https://renozao.github.io/doRNG/")
+ (synopsis "Generic reproducible parallel backend for foreach loops")
+ (description
+ "This package provides functions to perform reproducible parallel
+@code{foreach} loops, using independent random streams as generated by
+L'Ecuyer's combined multiple-recursive generator. It enables to easily
+convert standard @code{%dopar%} loops into fully reproducible loops,
+independently of the number of workers, the task scheduling strategy, or the
+chosen parallel environment and associated foreach backend.")
+ (license license:gpl2+)))
+
+(define-public r-blockmodeling
+ (package
+ (name "r-blockmodeling")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "blockmodeling" version))
+ (sha256
+ (base32
+ "11v9903y9dwlzaqp8sx0fsibcg82phvappddy37r8lnxd4vchsd2"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-doparallel" ,r-doparallel)
+ ("r-dorng" ,r-dorng)
+ ("r-foreach" ,r-foreach)
+ ("r-matrix" ,r-matrix)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/blockmodeling")
+ (synopsis "Generalized and classical blockmodeling of valued networks")
+ (description
+ "This package is primarily meant as an implementation of generalized
+blockmodeling for valued networks. In addition, measures of similarity or
+dissimilarity based on structural equivalence and regular equivalence (REGE
+algorithms) can be computed and partitioned matrices can be plotted.")
+ (license license:gpl2+)))
+
+(define-public r-upsetr
+ (package
+ (name "r-upsetr")
+ (version "1.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "UpSetR" version))
+ (sha256
+ (base32
+ "08vj7l92b8fpqyqwxshll2mhk3yhgyr74axvr2lf29z78bapymhz"))))
+ (properties `((upstream-name . "UpSetR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-plyr" ,r-plyr)
+ ("r-scales" ,r-scales)))
+ (home-page "https://github.com/hms-dbmi/UpSetR")
+ (synopsis "Visualize intersecting sets")
+ (description
+ "This package provides a more scalable alternative to Venn and Euler
+diagrams for visualizing intersecting sets. Create visualizations of
+intersecting sets using a novel matrix design, along with visualizations of
+several common set, element and attribute related tasks.")
+ (license license:expat)))
+
+;; This package includes a JavaScript file, which is not minified. When
+;; upgrading please check that there are no new minified JavaScript files.
+(define-public r-shinybs
+ (package
+ (name "r-shinybs")
+ (version "0.61")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "shinyBS" version))
+ (sha256
+ (base32
+ "0rhim4mbp4x9vvm7xkmpl7mhb9qd1gr96cr4dv330v863ra2kgji"))))
+ (properties `((upstream-name . "shinyBS")))
+ (build-system r-build-system)
+ ;; The tests spawn Shiny browser apps. They cannot be run
+ ;; non-interactively.
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-shiny" ,r-shiny)))
+ (home-page "https://ebailey78.github.io/shinyBS/")
+ (synopsis "Twitter Bootstrap components for Shiny")
+ (description
+ "This package adds additional Twitter Bootstrap components to Shiny.")
+ (license license:gpl3)))
+
+(define-public r-outliers
+ (package
+ (name "r-outliers")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "outliers" version))
+ (sha256
+ (base32
+ "0vcqfqmmv4yblyp3s6bd25r49pxb7hjzipiic5a82924nqfqzkmn"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/outliers/index.html")
+ (synopsis "Tests for outliers")
+ (description
+ "This package provides a collection of some tests commonly used for
+identifying outliers.")
+ (license license:gpl2+)))
+
+(define-public r-bayesm
+ (package
+ (name "r-bayesm")
+ (version "3.1-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "bayesm" version))
+ (sha256
+ (base32
+ "0y30cza92s6kgvmxjpr6f5g0qbcck7hslqp89ncprarhxiym2m28"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page "http://www.perossi.org/home/bsm-1")
+ (synopsis "Bayesian inference for marketing/micro-econometrics")
+ (description
+ "This package covers many important models used in marketing and
+micro-econometrics applications, including Bayes Regression (univariate or
+multivariate dep var), Bayes Seemingly Unrelated Regression (SUR), Binary and
+Ordinal Probit, Multinomial Logit (MNL) and Multinomial Probit (MNP),
+Multivariate Probit, Negative Binomial (Poisson) Regression, Multivariate
+Mixtures of Normals (including clustering), Dirichlet Process Prior Density
+Estimation with normal base, Hierarchical Linear Models with normal prior and
+covariates, Hierarchical Linear Models with a mixture of normals prior and
+covariates, Hierarchical Multinomial Logits with a mixture of normals prior
+and covariates, Hierarchical Multinomial Logits with a Dirichlet Process prior
+and covariates, Hierarchical Negative Binomial Regression Models, Bayesian
+analysis of choice-based conjoint data, Bayesian treatment of linear
+instrumental variables models, Analysis of Multivariate Ordinal survey data
+with scale usage heterogeneity, and Bayesian Analysis of Aggregate Random
+Coefficient Logit Models.")
+ (license license:gpl2+)))
+
+(define-public r-tensora
+ (package
+ (name "r-tensora")
+ (version "0.36.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tensorA" version))
+ (sha256
+ (base32
+ "176hjy3bvg3in62r97wxbhq187sjz6c1gwy9x6spaxl6k4my3zy7"))))
+ (properties `((upstream-name . "tensorA")))
+ (build-system r-build-system)
+ (home-page "http://www.stat.boogaart.de/tensorA")
+ (synopsis "Advanced tensor arithmetic with named indices")
+ (description
+ "This package provides convenience functions for advanced linear algebra
+with tensors and computation with datasets of tensors on a higher level
+abstraction. It includes Einstein and Riemann summing conventions, dragging,
+co- and contravariate indices, and parallel computations on sequences of
+tensors.")
+ (license license:gpl2+)))
+
+(define-public r-rarpack
+ (package
+ (name "r-rarpack")
+ (version "0.11-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rARPACK" version))
+ (sha256
+ (base32
+ "12h2y46xcfldhjdmm960swgn9b23zvkj5vg2bi42s9qxwgi02d63"))))
+ (properties `((upstream-name . "rARPACK")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-rspectra" ,r-rspectra)))
+ (home-page "https://github.com/yixuan/rARPACK")
+ (synopsis "Solvers for large scale eigenvalue and SVD problems")
+ (description
+ "This package was previously an R wrapper of the ARPACK library, and now
+a shell of the R package RSpectra, an R interface to the Spectra library for
+solving large scale eigenvalue/vector problems. The current version of
+rARPACK simply imports and exports the functions provided by RSpectra. New
+users of rARPACK are advised to switch to the RSpectra package.")
+ (license license:bsd-3)))
+
+(define-public r-compositions
+ (package
+ (name "r-compositions")
+ (version "1.40-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "compositions" version))
+ (sha256
+ (base32
+ "12mp05yi7jkdqg9iwh6bc9sx6sdxagcnrirznxy9hq8502p7238i"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bayesm" ,r-bayesm)
+ ("r-energy" ,r-energy)
+ ("r-robustbase" ,r-robustbase)
+ ("r-tensora" ,r-tensora)))
+ (home-page "http://www.stat.boogaart.de/compositions")
+ (synopsis "Compositional data analysis")
+ (description
+ "This package provides functions for the consistent analysis of
+compositional data (e.g. portions of substances) and positive
+numbers (e.g. concentrations).")
+ (license license:gpl2+)))
+
+(define-public r-cobs
+ (package
+ (name "r-cobs")
+ (version "1.3-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cobs" version))
+ (sha256
+ (base32
+ "1pqvz7czcchri4x79g78hbwyagb3bqzdqb047zkbdinyz067c7kb"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-quantreg" ,r-quantreg)
+ ("r-sparsem" ,r-sparsem)))
+ (home-page "https://cran.r-project.org/web/packages/cobs")
+ (synopsis "Constrained B-Splines (sparse matrix based)")
+ (description
+ "This package provides qualitatively constrained (regression) smoothing
+splines via linear programming and sparse matrices.")
+ (license license:gpl2+)))
+
+(define-public r-drimpute
+ (package
+ (name "r-drimpute")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "DrImpute" version))
+ (sha256
+ (base32
+ "1adzarrwqb282pqgx2yqswp9rpwd1naxsmar54kddr6qyd6b923b"))))
+ (properties `((upstream-name . "DrImpute")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page "https://github.com/ikwak2/DrImpute")
+ (synopsis "Imputing dropout events in single-cell RNA-Seq data")
+ (description
+ "This is an R package for imputing dropout events. Many statistical
+methods in cell type identification, visualization and lineage reconstruction
+do not account for dropout events. DrImpute can improve the performance of
+such software by imputing dropout events.")
+ (license license:gpl3)))
+
+(define-public r-gamlss-dist
+ (package
+ (name "r-gamlss-dist")
+ (version "5.1-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gamlss.dist" version))
+ (sha256
+ (base32
+ "1cd0vl9klcb849i8xwyjm8ihb1da92631j1rxdbnflgffkzrkya4"))))
+ (properties `((upstream-name . "gamlss.dist")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-mass" ,r-mass)))
+ (home-page "http://www.gamlss.org/")
+ (synopsis "Distributions for Generalized Additive Models for location scale and shape")
+ (description
+ "This package provides a set of distributions which can be used for
+modelling the response variables in Generalized Additive Models for Location
+Scale and Shape. The distributions can be continuous, discrete or mixed
+distributions. Extra distributions can be created, by transforming, any
+continuous distribution defined on the real line, to a distribution defined on
+ranges 0 to infinity or 0 to 1, by using a @code{log} or a @code{logit}
+transformation, respectively.")
+ ;; Either version of the GPL.
+ (license (list license:gpl2 license:gpl3))))
+
+;; This package includes JavaScript files, which are not minified. When
+;; upgrading please check that there are no new minified JavaScript files.
+(define-public r-shinyjs
+ (package
+ (name "r-shinyjs")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "shinyjs" version))
+ (sha256
+ (base32
+ "113zpijri0l80rlgrvqn6bxk0sdqgl79h7yhja2p76f9dc9i2sr8"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-htmltools" ,r-htmltools)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-shiny" ,r-shiny)))
+ (home-page "https://deanattali.com/shinyjs")
+ (synopsis "Improve the user experience of your Shiny apps")
+ (description
+ "Perform common useful JavaScript operations in Shiny apps that will
+greatly improve your apps without having to know any JavaScript. Examples
+include: hiding an element, disabling an input, resetting an input back to its
+original value, delaying code execution by a few seconds, and many more useful
+functions for both the end user and the developer. Shinyjs can also be used
+to easily call your own custom JavaScript functions from R.")
+ (license license:agpl3+)))
+
+;; This package includes minified JavaScript files. When upgrading please
+;; check that there are no new minified JavaScript files.
+(define-public r-colourpicker
+ (package
+ (name "r-colourpicker")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "colourpicker" version))
+ (sha256
+ (base32
+ "0z3v2083g7kwdp21x9s2n1crfh24agpdq3yxkcdzc2awn2pwpnpi"))))
+ (build-system r-build-system)
+ (arguments
+ `(#:modules ((guix build utils)
+ (guix build r-build-system)
+ (srfi srfi-1)
+ (ice-9 popen))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'process-javascript
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "inst"
+ (call-with-values
+ (lambda ()
+ (unzip2
+ `((,(assoc-ref inputs "js-salvattore")
+ "examples/colourInput/www/salvattore.min.js")
+ (,(assoc-ref inputs "js-jquery")
+ "htmlwidgets/lib/jquery/jquery.min.js")
+ ("www/shared/colourpicker/js/colourpicker.js"
+ "www/shared/colourpicker/js/colourpicker.min.js"))))
+ (lambda (sources targets)
+ (for-each (lambda (source target)
+ (format #t "Processing ~a --> ~a~%"
+ source target)
+ (delete-file target)
+ (let ((minified (open-pipe* OPEN_READ "uglify-js" source)))
+ (call-with-output-file target
+ (lambda (port)
+ (dump-port minified port)))))
+ sources targets))))
+ #t)))))
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-htmltools" ,r-htmltools)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-miniui" ,r-miniui)
+ ("r-shiny" ,r-shiny)
+ ("r-shinyjs" ,r-shinyjs)))
+ (native-inputs
+ `(("uglify-js" ,uglify-js)
+ ("js-jquery"
+ ,(origin
+ (method url-fetch)
+ (uri "https://code.jquery.com/jquery-3.3.1.js")
+ (sha256
+ (base32
+ "1b8zxrp6xwzpw25apn8j4qws0f6sr7qr7h2va5h1mjyfqvn29anq"))))
+ ("js-salvattore"
+ ,(origin
+ (method url-fetch)
+ (uri "https://raw.githubusercontent.com/rnmp/salvattore/v1.0.9/dist/salvattore.js")
+ (sha256
+ (base32
+ "0lfrbx7l9w5x89jpc6njmd0pk7h8fpvg537vklai2vf7b1r2nnk5"))))))
+ (home-page "https://github.com/daattali/colourpicker")
+ (synopsis "Color picker tool for Shiny and for selecting colors in plots")
+ (description
+ "This package provides a color picker that can be used as an input in
+Shiny apps or Rmarkdown documents. The color picker supports alpha opacity,
+custom color palettes, and many more options. A plot color helper tool is
+available as an RStudio Addin, which helps you pick colors to use in your
+plots. A more generic color picker RStudio Addin is also provided to let you
+select colors to use in your R code.")
+ (license license:expat)))
+
+(define-public r-ggextra
+ (package
+ (name "r-ggextra")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggExtra" version))
+ (sha256
+ (base32
+ "1m5zpn3l3p1y3d2692gyz50m63d58m2a3b7zb595kvcffdx2qr5b"))))
+ (properties `((upstream-name . "ggExtra")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-colourpicker" ,r-colourpicker)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gtable" ,r-gtable)
+ ("r-miniui" ,r-miniui)
+ ("r-scales" ,r-scales)
+ ("r-shiny" ,r-shiny)
+ ("r-shinyjs" ,r-shinyjs)))
+ (home-page "https://github.com/daattali/ggExtra")
+ (synopsis "Marginal histograms for ggplot2 and other enhancements")
+ (description
+ "This package is a collection of functions and layers to enhance ggplot2.
+The flagship function is @code{ggMarginal()}, which can be used to add
+marginal histograms/boxplots/density plots to ggplot2 scatterplots.")
+ (license license:expat)))
+
+(define-public r-minpack-lm
+ (package
+ (name "r-minpack-lm")
+ (version "1.2-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "minpack.lm" version))
+ (sha256
+ (base32
+ "18ym2pdql5vzngc7q5gn66d153hrfrnd8ilv8yh6vd7j7sx7vjql"))))
+ (properties `((upstream-name . "minpack.lm")))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/minpack.lm")
+ (synopsis "Levenberg-Marquardt Nonlinear Least-Squares algorithm")
+ (description
+ "The @code{nls.lm} function provides an R interface to @code{lmder} and
+@code{lmdif} from the MINPACK library, for solving nonlinear least-squares
+problems by a modification of the Levenberg-Marquardt algorithm, with support
+for lower and upper parameter bounds. The implementation can be used via
+@code{nls}-like calls using the @code{nlsLM} function.")
+ (license license:gpl3)))
+
+(define-public r-moments
+ (package
+ (name "r-moments")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "moments" version))
+ (sha256
+ (base32
+ "0f9y58w1hxcz4bqivirx25ywlmc80gbi6dfx5cnhkpdg1pk82fra"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/moments")
+ (synopsis "Moments, cumulants, skewness, kurtosis and related tests")
+ (description
+ "This package provides functions to calculate: moments, Pearson's
+kurtosis, Geary's kurtosis and skewness; it also includes tests related to
+them (Anscombe-Glynn, D'Agostino, Bonett-Seier).")
+ (license license:gpl2+)))
+
+(define-public r-msir
+ (package
+ (name "r-msir")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "msir" version))
+ (sha256
+ (base32
+ "1ipzgdffsqly3dp91pw7yp3h5cwn08l9qsj7cdmrykd42jc98950"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mclust" ,r-mclust)
+ ("r-rgl" ,r-rgl)))
+ (home-page "https://cran.r-project.org/web/packages/msir")
+ (synopsis "Model-based sliced inverse regression")
+ (description
+ "This is an R package for dimension reduction based on finite Gaussian
+mixture modeling of inverse regression.")
+ (license license:gpl2+)))
+
+(define-public r-pbivnorm
+ (package
+ (name "r-pbivnorm")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pbivnorm" version))
+ (sha256
+ (base32
+ "05jzrjqxzbcf6z245hlk7sjxiszv9paadaaimvcx5y5qgi87vhq7"))))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://github.com/brentonk/pbivnorm")
+ (synopsis "Vectorized bivariate normal CDF")
+ (description
+ "This package provides a vectorized R function for calculating
+probabilities from a standard bivariate normal CDF.")
+ (license license:gpl2+)))
+
+(define-public r-lavaan
+ (package
+ (name "r-lavaan")
+ (version "0.6-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lavaan" version))
+ (sha256
+ (base32
+ "0hw856kv11zqn6nd4216rh19i6xbnc1rh044r7jvvxkhzgbqkyxz"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-mnormt" ,r-mnormt)
+ ("r-numderiv" ,r-numderiv)
+ ("r-pbivnorm" ,r-pbivnorm)))
+ (home-page "http://lavaan.ugent.be")
+ (synopsis "Latent variable analysis")
+ (description
+ "This package provides tools to fit a variety of latent variable models,
+including confirmatory factor analysis, structural equation modeling and
+latent growth curve models.")
+ (license license:gpl2+)))
+
+(define-public r-nonnest2
+ (package
+ (name "r-nonnest2")
+ (version "0.5-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nonnest2" version))
+ (sha256
+ (base32
+ "1bq44qqmm59j91m0sny4xnqmxqlga4cm48qdsw8xfs3x19xwmxk6"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-compquadform" ,r-compquadform)
+ ("r-lavaan" ,r-lavaan)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-sandwich" ,r-sandwich)))
+ (home-page "https://cran.r-project.org/web/packages/nonnest2/")
+ (synopsis "Tests of non-nested models")
+ (description
+ "This package allows for testing of non-nested models. It includes tests
+of model distinguishability and of model fit that can be applied to both
+nested and non-nested models. The package also includes functionality to
+obtain confidence intervals associated with AIC and BIC.")
+ ;; Either version of the GPL.
+ (license (list license:gpl2 license:gpl3))))
+
+(define-public r-penalized
+ (package
+ (name "r-penalized")
+ (version "0.9-51")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "penalized" version))
+ (sha256
+ (base32
+ "1zcrwa93mc27qj3g4ayc2k895r6g8q0g6qb2azmvj7wqk750va7a"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-survival" ,r-survival)))
+ (home-page "https://cran.r-project.org/web/packages/penalized/")
+ (synopsis "Penalized estimation in GLMs and in the Cox model")
+ (description
+ "This package provides tools for fitting possibly high dimensional
+penalized regression models. The penalty structure can be any combination of
+an L1 penalty (lasso and fused lasso), an L2 penalty (ridge) and a positivity
+constraint on the regression coefficients. The supported regression models
+are linear, logistic and Poisson regression and the Cox Proportional Hazards
+model. Cross-validation routines allow optimization of the tuning
+parameters.")
+ (license license:gpl2+)))
+
+(define-public r-zim
+ (package
+ (name "r-zim")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ZIM" version))
+ (sha256
+ (base32
+ "0scyfjn4ilsvha3x41c3b8bcfi31hlhwm77wn2a8hj5dsvnnmzig"))))
+ (properties `((upstream-name . "ZIM")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-mass" ,r-mass)))
+ (home-page "https://github.com/biostatstudio/ZIM")
+ (synopsis "Zero-inflated models (ZIM) for count time series with excess zeros")
+ (description
+ "Analyze count time series with excess zeros. Two types of statistical
+models are supported: Markov regression and state-space models. They are also
+known as observation-driven and parameter-driven models respectively in the
+time series literature. The functions used for Markov regression or
+observation-driven models can also be used to fit ordinary regression models
+with independent data under the zero-inflated Poisson (ZIP) or zero-inflated
+negative binomial (ZINB) assumption. The package also contains miscellaneous
+functions to compute density, distribution, quantile, and generate random
+numbers from ZIP and ZINB distributions.")
+ (license license:gpl3)))
+
+(define-public r-nor1mix
+ (package
+ (name "r-nor1mix")
+ (version "1.2-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nor1mix" version))
+ (sha256
+ (base32
+ "1bvk888qml9qr7q703s7qzgm0sqfchcjdjqwqllm5vrjx0cnapj3"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/nor1mix/")
+ (synopsis "Normal (1-d) mixture models")
+ (description
+ "This package provides S3 classes and methods for one-dimensional normal
+mixture models, for, e.g., density estimation or clustering algorithms
+research and teaching; it provides the widely used Marron-Wand densities. It
+also provides tools for efficient random number generation and graphics.")
+ (license license:gpl2+)))
+
+(define-public r-beanplot
+ (package
+ (name "r-beanplot")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "beanplot" version))
+ (sha256
+ (base32
+ "0wmkr704fl8kdxkjwmaxw2a2h5dwzfgsgpncnk2p2wd4768jknj9"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/beanplot/")
+ (synopsis "Visualization via beanplots")
+ (description
+ "This package provides beanplots, an alternative to
+boxplot/stripchart/violin plots. It can be used to plot univariate comparison
+graphs.")
+ (license license:gpl2)))
+
+(define-public r-pbdzmq
+ (package
+ (name "r-pbdzmq")
+ (version "0.3-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pbdZMQ" version))
+ (sha256
+ (base32
+ "1jkfcfhspvqra7vbllrvkz3jx8j7d0ang6zzcdjgpb7200sc29mf"))))
+ (properties `((upstream-name . "pbdZMQ")))
+ (build-system r-build-system)
+ (inputs
+ `(("zeromq" ,zeromq)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://pbdr.org/")
+ (synopsis "R interface to ZeroMQ")
+ (description
+ "ZeroMQ is a well-known library for high-performance asynchronous
+messaging in scalable, distributed applications. This package provides high
+level R wrapper functions to easily utilize ZeroMQ. The main focus is on
+interactive client/server programming frameworks. A few wrapper functions
+compatible with @code{rzmq} are also provided.")
+ (license license:gpl3)))
+
+(define-public r-repr
+ (package
+ (name "r-repr")
+ (version "0.19.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "repr" version))
+ (sha256
+ (base32
+ "1mhhzakkagb8z568yx3p2ixs8fcifm7f8l2yq285zrz8jmnpckfx"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-base64enc" ,r-base64enc)
+ ("r-htmltools" ,r-htmltools)
+ ("r-jsonlite" ,r-jsonlite)))
+ (home-page "https://cran.r-project.org/web/packages/repr/")
+ (synopsis "Serializable representations")
+ (description
+ "This package provides string and binary representations of objects for
+several formats and MIME types.")
+ (license license:gpl3)))
+
+(define-public r-irdisplay
+ (package
+ (name "r-irdisplay")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "IRdisplay" version))
+ (sha256
+ (base32
+ "12chk53nf4zckgc4yl7gbvd7m5dvli52inp5b3f0zvcjvfncksli"))))
+ (properties `((upstream-name . "IRdisplay")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-repr" ,r-repr)))
+ (home-page "https://cran.r-project.org/web/packages/IRdisplay/")
+ (synopsis "Jupyter display machinery")
+ (description
+ "This package provides an interface to the rich display capabilities of
+Jupyter front-ends (e.g. Jupyter Notebook). It is designed to be used from a
+running IRkernel session.")
+ (license license:expat)))
+
+(define-public r-irkernel
+ (package
+ (name "r-irkernel")
+ (version "0.8.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "IRkernel" version))
+ (sha256
+ (base32
+ "1n0nc3paij8fgbp7l2b4405zk9k4y3gdi2bz6z8x6j0h5mi6k6a6"))))
+ (properties `((upstream-name . "IRkernel")))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-kernelspec
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "HOME" "/tmp")
+ (invoke "jupyter" "kernelspec" "install"
+ "--name" "ir"
+ "--prefix" out
+ (string-append out "/site-library/IRkernel/kernelspec"))
+ #t))))))
+ (inputs
+ `(("jupyter" ,jupyter)))
+ (propagated-inputs
+ `(("r-crayon" ,r-crayon)
+ ("r-digest" ,r-digest)
+ ("r-evaluate" ,r-evaluate)
+ ("r-irdisplay" ,r-irdisplay)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-pbdzmq" ,r-pbdzmq)
+ ("r-repr" ,r-repr)
+ ("r-uuid" ,r-uuid)))
+ (home-page "https://cran.r-project.org/web/packages/IRkernel/")
+ (synopsis "Native R kernel for Jupyter")
+ (description
+ "The R kernel for the Jupyter environment executes R code which the
+front-end (Jupyter Notebook or other front-ends) submits to the kernel via the
+network.")
+ (license license:expat)))
+
+(define-public r-gmodels
+ (package
+ (name "r-gmodels")
+ (version "2.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gmodels" version))
+ (sha256
+ (base32
+ "0s8kd8krqk4kwv2zqxpsfy3w8qdwf5naf4b5l383vidq9sil0qb2"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-gdata" ,r-gdata)
+ ("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/web/packages/gmodels/")
+ (synopsis "Various R programming tools for model fitting")
+ (description
+ "This package provides various R programming tools for model fitting.")
+ (license license:gpl2)))
+
+(define-public r-apcluster
+ (package
+ (name "r-apcluster")
+ (version "1.4.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "apcluster" version))
+ (sha256
+ (base32
+ "188hdfmwjjx3aic599nwmkzjqm9j9jighi5bly6qd43c1vj6ih2s"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-matrix" ,r-matrix)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://cran.r-project.org/web/packages/apcluster/")
+ (synopsis "Affinity propagation clustering")
+ (description
+ "This package implements affinity propagation clustering introduced by
+Frey and Dueck (2007). The package further provides leveraged affinity
+propagation and an algorithm for exemplar-based agglomerative clustering that
+can also be used to join clusters obtained from affinity propagation. Various
+plotting functions are available for analyzing clustering results.")
+ (license license:gpl2+)))
+
+(define-public r-valr
+ (package
+ (name "r-valr")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "valr" version))
+ (sha256
+ (base32
+ "14jhrwkiwmha3vlmm7b50n2xxyizj6ddmy89gb20mpzq7qhz1ika"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-broom" ,r-broom)
+ ("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-rcpp" ,r-rcpp)
+ ("r-readr" ,r-readr)
+ ("r-rlang" ,r-rlang)
+ ("r-stringr" ,r-stringr)
+ ("r-tibble" ,r-tibble)))
+ (home-page "http://github.com/rnabioco/valr")
+ (synopsis "Genome interval arithmetic in R")
+ (description
+ "This package enables you to read and manipulate genome intervals and
+signals. It provides functionality similar to command-line tool suites within
+R, enabling interactive analysis and visualization of genome-scale data.")
+ (license license:expat)))
+
+(define-public r-rematch2
+ (package
+ (name "r-rematch2")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rematch2" version))
+ (sha256
+ (base32
+ "16k0i5p7fa3qfxv59ijyn638wpz8n4jrkrnilqmh5g9l8f8bn4h6"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/r-lib/rematch2")
+ (synopsis "Tidy output from regular expression matching")
+ (description
+ "This package provides wrappers on @code{regexpr} and @code{gregexpr} to
+return the match results in tidy data frames.")
+ (license license:expat)))