summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e15f47ac3b..6ec08136d5 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1728,19 +1728,14 @@ or junctions, and always follows hard links.")
(define-public zstd
(package
(name "zstd")
- (version "1.3.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/facebook/zstd/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1sifbq18p0hc978g0pq8fymrlpzz1fcxqkbxfqk44z6v9jg5bqfn"))
- ;; Fix a regression that causes the tests to fail. Both patches
- ;; have been merged upstream and will be part of the next release.
- (patches (search-patches "zstd-fix-stdin-list-without-tty.patch"
- "zstd-fix-stdin-list-test.patch"))))
+ (version "1.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/facebook/zstd/releases/download/"
+ "v" version "/zstd-" version ".tar.gz"))
+ (sha256
+ (base32 "1525b31jmbiczjj1n58nckdzky4cdnbwcsil3zgy4cx03v0a0cp8"))))
(build-system gnu-build-system)
(arguments
`(#:phases