summaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm132
1 files changed, 118 insertions, 14 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 37a934b5a2..47241321fe 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
@@ -380,7 +380,7 @@ compression algorithm is currently LZMA2, which is used inside the .xz
container format. With typical files, XZ Utils create 30 % smaller output
than gzip and 15 % smaller output than bzip2.")
(license (list license:gpl2+ license:lgpl2.1+)) ; bits of both
- (home-page "http://tukaani.org/xz/")))
+ (home-page "https://tukaani.org/xz/")))
(define-public lzo
(package
@@ -994,7 +994,7 @@ respectively, based on the reference implementation from Google.")
(lambda _ (chdir "xdelta3")))
(add-after 'enter-build-directory 'autoconf
(lambda _ (zero? (system* "autoreconf" "-vfi")))))))
- (home-page "http://xdelta.com")
+ (home-page "http://xdelta.org")
(synopsis "Delta encoder for binary files")
(description "xdelta encodes only the differences between two binary files
using the VCDIFF algorithm and patch file format described in RFC 3284. It can
@@ -1042,22 +1042,16 @@ well as bzip2.")
(define-public bitshuffle
(package
(name "bitshuffle")
- (version "0.3.2")
+ (version "0.3.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "bitshuffle" version))
(sha256
(base32
- "01vcjrvsxjvv47y5hf9rps69zwv0vwd4ydhhms2jfs4rpcnlak6v"))))
+ "0ydawb01ghsvmw0lraczhrgvkjj97bpg98f1qqs1cnfp953mdd5v"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'make-required-dir
- (lambda _
- (mkdir-p "bitshuffle/plugin")
- #t)))))
+ `(#:tests? #f)) ; fail: https://github.com/h5py/h5py/issues/769
(inputs
`(("numpy" ,python-numpy)
("h5py" ,python-h5py)
@@ -1624,8 +1618,7 @@ or junctions, and always follows hard links.")
"HAVE_LZMA=0"
;; Not currently detected, but be explicit & avoid surprises later.
"HAVE_LZ4=0"
- "HAVE_ZLIB=0")
- #:test-target "test"))
+ "HAVE_ZLIB=0")))
(home-page "http://zstd.net/")
(synopsis "Zstandard real-time compression algorithm")
(description "Zstandard (@command{zstd}) is a lossless compression algorithm
@@ -1952,3 +1945,114 @@ type by using either Perl modules, or command-line tools on your system.")
(description "Tukaani-xz is an implementation of xz compression/decompression
algorithms in Java.")
(license license:public-domain)))
+
+(define-public lunzip
+ (package
+ (name "lunzip")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.savannah.gnu.org/releases/lzip/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ax3d9cp66z1qb9q7lfzg5bpx9630xrxgq9a5sw569wm0qqgpg2q"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "CC=gcc")))
+ (home-page "http://www.nongnu.org/lzip/lunzip.html")
+ (synopsis "Small, stand-alone lzip decompressor")
+ (description
+ "Lunzip is a decompressor for files in the lzip compression format (.lz),
+written as a single small C tool with no dependencies. This makes it
+well-suited to embedded and other systems without a C++ compiler, or for use in
+applications such as software installers that need only to decompress files,
+not compress them.
+Lunzip is intended to be fully compatible with the regular lzip package.")
+ (license (list license:bsd-2 ; carg_parser.[ch]
+ license:gpl2+)))) ; everything else
+
+(define-public clzip
+ (package
+ (name "clzip")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.savannah.gnu.org/releases/lzip/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1brvsnpihzj81cf4wk2x5bnr2qldlq0wncpdbzxmzvxapm1cq2yc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "CC=gcc")))
+ (home-page "http://www.nongnu.org/lzip/clzip.html")
+ (synopsis "Small, stand-alone lzip compressor and decompressor")
+ (description
+ "Clzip is a compressor and decompressor for files in the lzip compression
+format (.lz), written as a single small C tool with no dependencies. This makes
+it well-suited to embedded and other systems without a C++ compiler, or for use
+in other applications like package managers.
+Clzip is intended to be fully compatible with the regular lzip package.")
+ (license (list license:bsd-2 ; carg_parser.[ch], lzd in clzip.texi
+ license:gpl2+))))
+
+(define-public lzlib
+ (package
+ (name "lzlib")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.savannah.gnu.org/releases/lzip/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "13mssf3hrcnmd4ijbqnxfk0zgj1q5lvpxxkm1hmrbl1h73czhwi4"))))
+ (build-system gnu-build-system)
+ ;; The included minilzip binary is only ~16 smaller than the ‘real’ lzip.
+ ;; It's used during the test suite, but don't be tempted to install it.
+ (arguments
+ `(#:configure-flags
+ (list "CC=gcc"
+ "--enable-shared"))) ; only static (.a) is built by default
+ (home-page "http://www.nongnu.org/lzip/lzlib.html")
+ (synopsis "Lzip data compression C library")
+ (description
+ "Lzlib is a C library for in-memory LZMA compression and decompression in
+the lzip format. It supports integrity checking of the decompressed data, and
+all functions are thread-safe. The library should never crash, even in case of
+corrupted input.")
+ (license (list license:bsd-2 ; the library itself
+ license:gpl2+)))) ; main.c (i.e. minilzip used by tests)
+
+(define-public plzip
+ (package
+ (name "plzip")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.savannah.gnu.org/releases/lzip/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0z2cs6vn4xl65wakd013xl3sdfpg8dr0cvcjwc2slh8y9bz7j7ax"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("lzlib" ,lzlib)))
+ (home-page "http://www.nongnu.org/lzip/plzip.html")
+ (synopsis "Parallel lossless data compressor for the lzip format")
+ (description
+ "Plzip is a massively parallel (multi-threaded) lossless data compressor
+and decompressor that uses the lzip file format (.lz). Files produced by plzip
+are fully compatible with lzip and can be rescued with lziprecover.
+On multiprocessor machines, plzip can compress and decompress large files much
+faster than lzip, at the cost of a slightly reduced compression ratio (0.4% to
+2%). The number of usable threads is limited by file size: on files of only a
+few MiB, plzip is no faster than lzip.
+Files that were compressed with regular lzip will also not be decompressed
+faster by plzip, unless the @code{-b} option was used: lzip usually produces
+single-member files which can't be decompressed in parallel.")
+ (license (list license:bsd-2 ; arg_parser.{cc,h}
+ license:gpl2+)))) ; everything else