aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 941844b870..a9e942efd5 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
+;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
(define-module (gnu packages compression)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -225,6 +227,36 @@ decompression.")
"See LICENSE in the distribution."))
(home-page "http://www.bzip.org/"))))
+(define-public pbzip2
+ (package
+ (name "pbzip2")
+ (version "1.1.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/pbzip2/"
+ (version-major+minor version) "/" version
+ "/+download/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vk6065dv3a47p86vmp8hv3n1ygd9hraz0gq89gvzlx7lmcb6fsp"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("bzip2", bzip2)))
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))
+ #:make-flags (list (string-append "PREFIX=" %output))))
+ (home-page "http://compression.ca/pbzip2/")
+ (synopsis "Parallel bzip2 implementation")
+ (description
+ "Pbzip2 is a parallel implementation of the bzip2 block-sorting file
+compressor that uses pthreads and achieves near-linear speedup on SMP machines.
+The output of this version is fully compatible with bzip2 v1.0.2 (i.e. anything
+compressed with pbzip2 can be decompressed with bzip2).")
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))
+
(define-public xz
(package
(name "xz")