summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index d06aa0a369..ff34392865 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1887,6 +1887,9 @@ the bootstrap environment."
((#:configure-flags _ ''())
`(list "--without-ensurepip"
"--without-threads"))
+ ;; Clear #:make-flags, such that changes to the regular
+ ;; Python package won't interfere with this one.
+ ((#:make-flags _ ''()) ''())
((#:phases phases)
`(modify-phases ,phases
(add-before 'configure 'disable-modules
@@ -1897,7 +1900,8 @@ the bootstrap environment."
;; Prevent the 'ossaudiodev' extension from being
;; built, since it requires Linux headers.
(("'linux', ") ""))
- #t))))
+ #t))
+ (delete 'set-TZDIR)))
((#:tests? _ #f) #f))))))
(package-with-bootstrap-guile
(package-with-explicit-inputs python %boot0-inputs