summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm49
1 files changed, 17 insertions, 32 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index e2c244c1a7..806a7396e9 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,7 +51,7 @@
(define-public cmake-minimal
(package
(name "cmake-minimal")
- (version "3.15.1")
+ (version "3.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -58,7 +59,7 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "1xyprly3sf4wi0n1x79k4n22yxm6pb7fv70gqr9lvc7qv14cbphq"))
+ "0pwcgvk75577rdizpzjrk2n43a6l7rvfhmhn7sd6xarwqrb6b9bd"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -74,7 +75,8 @@
"cmliblzma"
;; "cmlibuv"
"cmzlib"))
- #t)))))
+ #t)))
+ (patches (search-patches "cmake-curl-certificates.patch"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -99,6 +101,8 @@
(let ((skipped-tests
(list "BundleUtilities" ; This test fails on Guix.
"CTestTestSubdir" ; This test fails to build 2 of the 3 tests.
+ ;; This test requires 'ldconfig' which is not available in Guix.
+ "RunCMake.install"
;; These tests requires network access.
"CTestCoverageCollectGCOV"
"CTestTestUpload")))
@@ -123,7 +127,7 @@
;; files.
(substitute*
'("Modules/CompilerId/Xcode-3.pbxproj.in"
- "Modules/CPack.RuntimeScript.in"
+ "Modules/Internal/CPack/CPack.RuntimeScript.in"
"Source/cmGlobalXCodeGenerator.cxx"
"Source/cmLocalUnixMakefileGenerator3.cxx"
"Source/cmExecProgramCommand.cxx"
@@ -145,16 +149,17 @@
(replace 'configure
(lambda* (#:key (configure-flags '()) #:allow-other-keys)
(apply invoke "./configure" configure-flags))))))
- (inputs
+ (native-inputs
`(("bzip2" ,bzip2)
("curl" ,curl)
("expat" ,expat)
("file" ,file)
("libarchive" ,libarchive)
("libuv" ,libuv)
- ("ncurses" ,ncurses) ; required for ccmake
("rhash" ,rhash)
("zlib" ,zlib)))
+ (inputs
+ `(("ncurses" ,ncurses))) ; required for ccmake
(native-search-paths
(list (search-path-specification
(variable "CMAKE_PREFIX_PATH")
@@ -207,33 +212,13 @@ and workspaces that can be used in the compiler environment of your choice.")
(outputs '("out" "doc"))
(properties (alist-delete 'hidden? (package-properties cmake-minimal)))))
-(define-public cmake/fixed
- ;; This is a variant of CMake that fixes X.509 certificate lookup:
- ;; <https://issues.guix.gnu.org/issue/37371>.
- (package
- (inherit cmake)
- (version (string-append (package-version cmake) "-1"))
- (source (origin
- (inherit (package-source cmake))
- (patches
- (append (search-patches "cmake-curl-certificates.patch")
- (origin-patches (package-source cmake))))))))
-
-(define-public cmake-3.15.5
- ;; CMake 3.15.5 fixes some issues, but declare another version to
- ;; avoid triggering the rebuild of all CMake-based packages.
- ;; See <https://issues.guix.gnu.org/issue/38060>.
+(define-public cmake-minimal-cross
(package
- (inherit cmake)
- (version "3.15.5")
- (source (origin
- (inherit (package-source cmake))
- (uri (string-append "https://www.cmake.org/files/v"
- (version-major+minor version)
- "/cmake-" version ".tar.gz"))
- (sha256
- (base32
- "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))))))
+ (inherit cmake-minimal)
+ (name "cmake-minimal-cross")
+ (native-search-paths '())
+ (search-paths
+ (package-native-search-paths cmake-minimal))))
(define-public emacs-cmake-mode
(package