summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm300
1 files changed, 199 insertions, 101 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 2d2827ffee..cf3bc406bc 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -5,10 +5,12 @@
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +34,7 @@
#:use-module (guix utils)
#:use-module (guix deprecation)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system emacs)
#:use-module (gnu packages)
#:use-module (gnu packages backup)
@@ -39,19 +42,63 @@
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages file)
+ #:use-module (gnu packages hurd)
#:use-module (gnu packages libevent)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages xml)
+ #:use-module (ice-9 match)
#:use-module (srfi srfi-1))
-;;; This minimal variant of CMake does not include the documentation. It is
-;;; used by the cmake-build-system.
-(define-public cmake-minimal
+;;; Build phases shared between 'cmake-bootstrap' and the later variants
+;;; that use cmake-build-system.
+(define %common-build-phases
+ `((add-after 'unpack 'split-package
+ ;; Remove files that have been packaged in other package recipes.
+ (lambda _
+ (delete-file "Auxiliary/cmake-mode.el")
+ (substitute* "Auxiliary/CMakeLists.txt"
+ ((".*cmake-mode.el.*") ""))
+ #t))
+ (add-before 'configure 'patch-bin-sh
+ (lambda _
+ ;; Replace "/bin/sh" by the right path in... a lot of
+ ;; files.
+ (substitute*
+ '("Modules/CompilerId/Xcode-3.pbxproj.in"
+ "Modules/Internal/CPack/CPack.RuntimeScript.in"
+ "Source/cmGlobalXCodeGenerator.cxx"
+ "Source/cmLocalUnixMakefileGenerator3.cxx"
+ "Source/cmExecProgramCommand.cxx"
+ "Utilities/Release/release_cmake.cmake"
+ "Tests/CMakeLists.txt"
+ "Tests/RunCMake/File_Generate/RunCMakeTest.cmake")
+ (("/bin/sh") (which "sh")))
+ #t))))
+
+(define %common-disabled-tests
+ '(;; This test copies libgcc_s.so.1 from GCC and tries to modify its RPATH,
+ ;; but does not cope with the file being read-only.
+ "BundleUtilities"
+ ;; This test requires network access.
+ "CTestTestUpload"
+ ;; This test requires 'ldconfig' which is not available in Guix.
+ "RunCMake.install"))
+
+(define %preserved-third-party-files
+ '(;; 'Source/cm_getdate.c' includes archive_getdate.c wholesale, so it must
+ ;; be available along with the required headers.
+ "Utilities/cmlibarchive/libarchive/archive_getdate.c"
+ "Utilities/cmlibarchive/libarchive/archive_getdate.h"))
+
+;;; The "bootstrap" CMake. It is used to build 'cmake-minimal' below, as well
+;;; as any dependencies that need cmake-build-system.
+(define-public cmake-bootstrap
(package
- (name "cmake-minimal")
- (version "3.15.1")
+ (name "cmake-bootstrap")
+ (version "3.16.5")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -59,23 +106,50 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "1xyprly3sf4wi0n1x79k4n22yxm6pb7fv70gqr9lvc7qv14cbphq"))
- (modules '((guix build utils)))
+ "1z4bb8z6b4dvq5hrvajrf1hyybqay3xybyimf71w1jgcp180nxjz"))
+ (modules '((guix build utils)
+ (ice-9 ftw)))
(snippet
- '(begin
- ;; Drop bundled software.
- (with-directory-excursion "Utilities"
- (for-each delete-file-recursively
- '("cmbzip2"
- ;; "cmcompress"
- "cmcurl"
- "cmexpat"
- ;; "cmjsoncpp"
- ;; "cmlibarchive"
- "cmliblzma"
- ;; "cmlibuv"
- "cmzlib"))
- #t)))))
+ `(begin
+ ;; CMake bundles its dependencies in the "Utilities" directory.
+ ;; Delete those to ensure the system libraries are used.
+ (define preserved-files
+ '(,@%preserved-third-party-files
+ ;; Use the bundled JsonCpp during bootstrap to work around
+ ;; a circular dependency. TODO: JsonCpp can be built with
+ ;; Meson instead of CMake, but meson-build-system currently
+ ;; does not support cross-compilation.
+ "Utilities/cmjsoncpp"
+ ;; LibUV is required to bootstrap the initial build system.
+ "Utilities/cmlibuv"))
+
+ (file-system-fold (lambda (dir stat result) ;enter?
+ (or (string=? "Utilities" dir) ;init
+ ;; The bundled dependencies are
+ ;; distinguished by having a "cm"
+ ;; prefix to their upstream names.
+ (and (string-prefix? "Utilities/cm" dir)
+ (not (member dir preserved-files)))))
+ (lambda (file stat result) ;leaf
+ (unless (or (member file preserved-files)
+ ;; Preserve top-level files.
+ (string=? "Utilities"
+ (dirname file)))
+ (delete-file file)))
+ (const #t) ;down
+ (lambda (dir stat result) ;up
+ (when (equal? (scandir dir) '("." ".."))
+ (rmdir dir)))
+ (const #t) ;skip
+ (lambda (file stat errno result)
+ (format (current-error-port)
+ "warning: failed to delete ~a: ~a~%"
+ file (strerror errno)))
+ #t
+ "Utilities"
+ lstat)
+ #t))
+ (patches (search-patches "cmake-curl-certificates.patch"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -86,7 +160,7 @@
(string-append "--parallel=" parallel-job-count)
(string-append "--prefix=" out)
"--system-libs"
- "--no-system-jsoncpp" ; FIXME: Circular dependency.
+ "--no-system-jsoncpp"
;; By default, the man pages and other docs land
;; in PREFIX/man and PREFIX/doc, but we want them
;; in share/{man,doc}. Note that unlike
@@ -95,14 +169,18 @@
;; to --mandir and --docdir.
"--mandir=share/man"
,(string-append "--docdir=share/doc/cmake-"
- (version-major+minor version))))
+ (version-major+minor version))
+
+ ;; By default CMake is built without any optimizations. Use
+ ;; the recommended Release target for a ~2.5x speedup.
+ "--" "-DCMAKE_BUILD_TYPE=Release"))
#:make-flags
(let ((skipped-tests
- (list "BundleUtilities" ; This test fails on Guix.
+ (list ,@%common-disabled-tests
"CTestTestSubdir" ; This test fails to build 2 of the 3 tests.
- ;; These tests requires network access.
- "CTestCoverageCollectGCOV"
- "CTestTestUpload")))
+ ;; This test fails when ARGS (below) is in use, see
+ ;; <https://gitlab.kitware.com/cmake/cmake/issues/17165>.
+ "CTestCoverageCollectGCOV")))
(list
(string-append
;; These arguments apply for the tests only.
@@ -111,29 +189,7 @@
" --exclude-regex ^\\(" (string-join skipped-tests "\\|") "\\)$")))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'split-package
- ;; Remove files that have been packaged in other package recipes.
- (lambda _
- (delete-file "Auxiliary/cmake-mode.el")
- (substitute* "Auxiliary/CMakeLists.txt"
- ((".*cmake-mode.el.*") ""))
- #t))
- (add-before 'configure 'patch-bin-sh
- (lambda _
- ;; Replace "/bin/sh" by the right path in... a lot of
- ;; files.
- (substitute*
- '("Modules/CompilerId/Xcode-3.pbxproj.in"
- "Modules/CPack.RuntimeScript.in"
- "Source/cmGlobalXCodeGenerator.cxx"
- "Source/cmLocalUnixMakefileGenerator3.cxx"
- "Source/cmExecProgramCommand.cxx"
- "Utilities/Release/release_cmake.cmake"
- "Utilities/cmlibarchive/libarchive/archive_write_set_format_shar.c"
- "Tests/CMakeLists.txt"
- "Tests/RunCMake/File_Generate/RunCMakeTest.cmake")
- (("/bin/sh") (which "sh")))
- #t))
+ ,@%common-build-phases
(add-before 'configure 'set-paths
(lambda _
;; Help cmake's bootstrap process to find system libraries
@@ -148,18 +204,31 @@
(apply invoke "./configure" configure-flags))))))
(inputs
`(("bzip2" ,bzip2)
- ("curl" ,curl)
+ ("curl" ,curl-minimal)
("expat" ,expat)
("file" ,file)
("libarchive" ,libarchive)
- ("libuv" ,libuv)
- ("ncurses" ,ncurses) ; required for ccmake
+ ,@(if (hurd-target?)
+ '()
+ `(("libuv" ,libuv))) ;not supported on the Hurd
+ ("ncurses" ,ncurses) ;required for ccmake
("rhash" ,rhash)
("zlib" ,zlib)))
(native-search-paths
(list (search-path-specification
(variable "CMAKE_PREFIX_PATH")
- (files '("")))))
+ (files '("")))
+ ;; "cmake-curl-certificates.patch" changes CMake to honor 'SSL_CERT_DIR'
+ ;; and 'SSL_CERT_FILE', hence these search path entries.
+ (search-path-specification
+ (variable "SSL_CERT_DIR")
+ (separator #f) ;single entry
+ (files '("etc/ssl/certs")))
+ (search-path-specification
+ (variable "SSL_CERT_FILE")
+ (file-type 'regular)
+ (separator #f) ;single entry
+ (files '("etc/ssl/certs/ca-certificates.crt")))))
(home-page "https://cmake.org/")
(synopsis "Cross-platform build system")
(description
@@ -169,23 +238,84 @@ and compiler independent configuration files. CMake generates native makefiles
and workspaces that can be used in the compiler environment of your choice.")
(properties '((hidden? . #t)))
(license (list license:bsd-3 ; cmake
- license:bsd-4 ; cmcompress
- license:bsd-2 ; cmlibarchive
license:expat ; cmjsoncpp is dual MIT/public domain
license:public-domain)))) ; cmlibarchive/archive_getdate.c
+;;; This minimal variant of CMake does not include the documentation. It is
+;;; used by the cmake-build-system.
+(define-public cmake-minimal
+ (package
+ (inherit cmake-bootstrap)
+ (name "cmake-minimal")
+ (source (origin
+ (inherit (package-source cmake-bootstrap))
+ (snippet
+ (match (origin-snippet (package-source cmake-bootstrap))
+ ((_ _ exp ...)
+ ;; Now we can delete the remaining software bundles.
+ (append `(begin
+ (define preserved-files ',%preserved-third-party-files))
+ exp))))))
+ (inputs
+ `(("curl" ,curl)
+ ("jsoncpp" ,jsoncpp)
+ ,@(alist-delete "curl" (package-inputs cmake-bootstrap))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "-DCMAKE_USE_SYSTEM_LIBRARIES=ON"
+ (string-append "-DCMAKE_DOC_DIR=share/doc/cmake-"
+ ,(version-major+minor (package-version
+ cmake-bootstrap))))
+
+ ;; This is the CMake used in cmake-build-system. Ensure compiler
+ ;; optimizations are enabled to save size and CPU cycles.
+ #:build-type "Release"
+ #:phases
+ (modify-phases %standard-phases
+ ,@%common-build-phases
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (let ((skipped-tests (list ,@%common-disabled-tests
+ ;; This test requires the bundled libuv.
+ "BootstrapTest")))
+ (if tests?
+ (begin
+ (invoke "ctest" "-j" (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")
+ "--exclude-regex"
+ (string-append "^(" (string-join skipped-tests "|") ")$")))
+ (format #t "test suite not run~%"))
+ #t))))
+ ,@(if (%current-target-system)
+ '()
+ `(#:cmake ,cmake-bootstrap))))))
+
+;;; The "user-facing" CMake, now with manuals and HTML documentation.
(define-public cmake
(package
(inherit cmake-minimal)
(name "cmake")
(arguments
(substitute-keyword-arguments (package-arguments cmake-minimal)
- ((#:configure-flags configure-flags ''())
- `(append ,configure-flags
- ;; Extra configure flags used to generate the documentation.
- '("--sphinx-info"
- "--sphinx-man"
- "--sphinx-html")))
+ ;; Use cmake-minimal this time.
+ ((#:cmake _ #f)
+ (if (%current-target-system)
+ cmake-minimal-cross
+ cmake-minimal))
+
+ ;; Enable debugging information for convenience.
+ ((#:build-type _ #f) "RelWithDebInfo")
+
+ ((#:configure-flags flags ''())
+ `(append (list "-DSPHINX_INFO=ON" "-DSPHINX_MAN=ON" "-DSPHINX_HTML=ON"
+ (string-append "-DCMAKE_DOC_DIR=share/doc/cmake-"
+ ,(version-major+minor (package-version
+ cmake-minimal)))
+ "-DCMAKE_INFO_DIR=share/info"
+ "-DCMAKE_MAN_DIR=share/man")
+ ,flags))
((#:phases phases)
`(modify-phases ,phases
(add-after 'install 'move-html-doc
@@ -208,45 +338,13 @@ and workspaces that can be used in the compiler environment of your choice.")
(outputs '("out" "doc"))
(properties (alist-delete 'hidden? (package-properties cmake-minimal)))))
-(define-public cmake-3.15.5
- ;; CMake 3.15.5 fixes some issues, but declare another version to
- ;; avoid triggering the rebuild of all CMake-based packages.
- ;; See <https://issues.guix.gnu.org/issue/38060>.
- ;;
- ;; Furthermore, this variant fixes X.509 certificate lookup:
- ;; <https://issues.guix.gnu.org/issue/37371>.
+(define-public cmake-minimal-cross
(package
- (inherit cmake)
- (version "3.15.5")
- (source (origin
- (inherit (package-source cmake))
- (uri (string-append "https://www.cmake.org/files/v"
- (version-major+minor version)
- "/cmake-" version ".tar.gz"))
- (sha256
- (base32
- "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))
- (patches
- (append (search-patches "cmake-curl-certificates.patch")
- (origin-patches (package-source cmake))))))
-
- (native-search-paths
- ;; "cmake-curl-certificates.patch" changes CMake to honor 'SSL_CERT_DIR'
- ;; and 'SSL_CERT_FILE', hence these search path entries.
- (append (list (search-path-specification
- (variable "SSL_CERT_DIR")
- (separator #f) ;single entry
- (files '("etc/ssl/certs")))
- (search-path-specification
- (variable "SSL_CERT_FILE")
- (file-type 'regular)
- (separator #f) ;single entry
- (files '("etc/ssl/certs/ca-certificates.crt"))))
- (package-native-search-paths cmake)))))
-
-;; This was cmake@3.15.1 plus "cmake-curl-certificates.patch".
-(define-deprecated cmake/fixed cmake-3.15.5)
-(export cmake/fixed)
+ (inherit cmake-minimal)
+ (name "cmake-minimal-cross")
+ (native-search-paths '())
+ (search-paths
+ (package-native-search-paths cmake-minimal))))
(define-public emacs-cmake-mode
(package