summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm46
1 files changed, 21 insertions, 25 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 40f341fb64..02c1d52740 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -619,14 +619,14 @@ standard library.")
(define-public python-pytest
(package
(name "python-pytest")
- (version "3.5.0")
+ (version "3.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest" version))
(sha256
(base32
- "1q832zd07zak2lyxbycxjydh0jp7y3hvawjqzlvra6aghz8r3r7s"))))
+ "17grcfvd6ggvvqmprwv5y8g319nayam70hr43ssjwj40ws27z858"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -642,9 +642,11 @@ standard library.")
(string-append "@pytest.mark.skip"
"(reason=\"Assumes that /usr exists.\")\n "
line)))
- #t)))))
+ #t))
+ (replace 'check (lambda _ (invoke "pytest" "-vv"))))))
(propagated-inputs
- `(("python-attrs" ,python-attrs-bootstrap)
+ `(("python-atomicwrites" ,python-atomicwrites)
+ ("python-attrs" ,python-attrs-bootstrap)
("python-more-itertools" ,python-more-itertools)
("python-pluggy" ,python-pluggy)
("python-py" ,python-py)
@@ -655,6 +657,7 @@ standard library.")
("python-hypothesis" ,python-hypothesis)
("python-nose" ,python-nose)
("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest-bootstrap)
("python-setuptools-scm" ,python-setuptools-scm)))
(home-page "http://pytest.org")
(synopsis "Python testing library")
@@ -672,6 +675,7 @@ and many external plugins.")
(inherit pytest)
(propagated-inputs
`(("python2-funcsigs" ,python2-funcsigs)
+ ("python2-pathlib2" ,python2-pathlib2)
,@(package-propagated-inputs pytest))))))
(define-public python-pytest-bootstrap
@@ -688,19 +692,20 @@ and many external plugins.")
(package (inherit pytest)
(propagated-inputs
`(("python2-funcsigs" ,python2-funcsigs-bootstrap)
+ ("python2-pathlib2" ,python2-pathlib2-bootstrap)
,@(package-propagated-inputs pytest))))))
(define-public python-pytest-cov
(package
(name "python-pytest-cov")
- (version "2.4.0")
+ (version "2.5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-cov" version))
(sha256
(base32
- "03c2qc42r4bczyw93gd7n0qi1h1jfhw7fnbhi33c3vp1hs81gm2k"))))
+ "0bbfpwdh9k3636bxc88vz9fa7vf4akchgn513ql1vd0xy4n7bah3"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -729,26 +734,15 @@ supports coverage of subprocesses.")
(define-public python-pytest-runner
(package
(name "python-pytest-runner")
- (version "2.11.1")
+ (version "4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-runner" version))
(sha256
(base32
- "1cw978kqqcq916b9gfns1qjqvg33c5ail5jhw9054dsynkm32flq"))))
+ "1gkpyphawxz38ni1gdq1fmwyqcg02m7ypzqvv46z06crwdxi2gyj"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; The fancy way of setting the version with setuptools_scm does not
- ;; seem to work here.
- (add-after 'unpack 'set-version
- (lambda _
- (substitute* "docs/conf.py"
- (("version = setuptools_scm\\.get_version\\(root='\\.\\.')")
- (string-append "version = \"" ,version "\"")))
- #t)))))
(native-inputs
`(("python-pytest" ,python-pytest-bootstrap)
("python-setuptools-scm" ,python-setuptools-scm)))
@@ -765,14 +759,14 @@ supports coverage of subprocesses.")
(define-public python-pytest-mock
(package
(name "python-pytest-mock")
- (version "1.6.3")
+ (version "1.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-mock" version))
(sha256
(base32
- "075v7b2wm5f839r1a30n21wfk5rfqp3d05q7zb9jlb2wmxki23cj"))))
+ "1h6lgpmsvs9s8j2s80v06f9f3iaw1n1rc51mbrxk1f12sw4q56nq"))))
(build-system python-build-system)
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)))
@@ -885,7 +879,8 @@ subprocess and see the output as well as any file modifications.")
(uri (pypi-uri "testtools" version))
(sha256
(base32
- "0n8519lk8aaa91vymz842831181wf7fss98hyllhygi3z1nfq9sq"))))
+ "0n8519lk8aaa91vymz842831181wf7fss98hyllhygi3z1nfq9sq"))
+ (patches (search-patches "python-testtools.patch"))))
(build-system python-build-system)
(arguments '(#:tests? #f))
(propagated-inputs
@@ -1421,16 +1416,17 @@ normally the case.")
(define-public python-hypothesis
(package
(name "python-hypothesis")
- (version "3.52.0")
+ (version "3.70.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "hypothesis" version))
(sha256
(base32
- "0g54cypfi5qj6cgxfr7l1nb41r1cqhhngx4qxn4ga9h720rcsbr8"))))
+ "1rshs1japfmwgar98yrkq4hg4z2q76hlnq7w2n3lfbjnscn1jd9b"))))
(build-system python-build-system)
(native-inputs
- `(("python-flake8" ,python-flake8)
+ `(;; FIXME: Change to python-flake8 in the next rebuild cycle.
+ ("python-flake8" ,python-flake8-3.5)
("python-pytest" ,python-pytest-bootstrap)))
(propagated-inputs
`(("python-attrs" ,python-attrs-bootstrap)