summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 43f3892cde..4229578f86 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
+;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
@@ -370,8 +370,8 @@ and it supports a very flexible form of test discovery.")
(license license:lgpl3+)))
(define-public go-gopkg.in-check.v1
- (let ((commit "20d25e2804050c1cd24a7eea1e7a6447dd0e74ec")
- (revision "0"))
+ (let ((commit "788fd78401277ebd861206a03c884797c6ec5541")
+ (revision "1"))
(package
(name "go-gopkg.in-check.v1")
(version (git-version "0.0.0" revision commit))
@@ -383,10 +383,12 @@ and it supports a very flexible form of test discovery.")
(file-name (git-file-name name version))
(sha256
(base32
- "0k1m83ji9l1a7ng8a7v40psbymxasmssbrrhpdv2wl4rhs0nc3np"))))
+ "0v3bim0j375z81zrpr5qv42knqs0y2qv2vkjiqi5axvb78slki1a"))))
(build-system go-build-system)
(arguments
'(#:import-path "gopkg.in/check.v1"))
+ (propagated-inputs
+ `(("go-github-com-kr-pretty" ,go-github-com-kr-pretty)))
(synopsis "Rich testing extension for Go's testing package")
(description
"@code{check} is a rich testing extension for Go's testing package.")
@@ -1995,14 +1997,13 @@ create data based on random numbers and yet remain repeatable.")
(define-public python-nose-timer
(package
(name "python-nose-timer")
- (version "0.7.3")
+ (version "0.7.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "nose-timer" version))
(sha256
- (base32
- "0hfz5aqnhf493i9kyb6prm4zm8vx7wmfsyg3nvsnh24lzh2kwx44"))))
+ (base32 "04inck7l1sgkjbiinhifxk45wk2b3czbwh1x2a390hi183fq1q12"))))
(build-system python-build-system)
(propagated-inputs
`(("python-nose" ,python-nose)
@@ -2018,14 +2019,13 @@ create data based on random numbers and yet remain repeatable.")
(define-public python-freezegun
(package
(name "python-freezegun")
- (version "0.3.10")
+ (version "0.3.11")
(source
(origin
(method url-fetch)
(uri (pypi-uri "freezegun" version))
(sha256
- (base32
- "08m6b42yxb9hk5lv747v9n2qsxyadmkb0k6yg0gxdanwap0slg3h"))))
+ (base32 "1nh0fzqjwg88n57k3qa8mxnmiwrr7lqyd5xvc96qn5g8zcxv8fg8"))))
(build-system python-build-system)
(native-inputs
`(("python-mock" ,python-mock)
@@ -2055,13 +2055,13 @@ time by mocking the datetime module.")
(define-public python-flexmock
(package
(name "python-flexmock")
- (version "0.10.2")
+ (version "0.10.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "flexmock" version))
(sha256
(base32
- "0arc6njvs6i9v9hgvzk5m50296g7zy5m9d7pyb43vdsdgxrci5gy"))))
+ "031c624pdqm7cc0xh4yz5k69gqxn2bbrjz13s17684q5shn0ik21"))))
(build-system python-build-system)
(home-page "https://flexmock.readthedocs.org")
(synopsis "Testing library for Python")