summaryrefslogtreecommitdiff
path: root/gnu/packages/certs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/certs.scm')
-rw-r--r--gnu/packages/certs.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 03549af0ef..bb8facbc89 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -170,10 +170,9 @@ taken from the NSS package and thus ultimately from the Mozilla project.")
;; Create hash symlinks suitable for OpenSSL ('SSL_CERT_DIR' and
;; similar.)
(chdir (string-append %output "/etc/ssl/certs"))
- (unless (zero? (system* (string-append perl "/bin/perl")
- (string-append openssl "/bin/c_rehash")
- "."))
- (error "'c_rehash' failed" openssl))))))
+ (invoke (string-append perl "/bin/perl")
+ (string-append openssl "/bin/c_rehash")
+ ".")))))
(native-inputs
`(("openssl" ,openssl)
("perl" ,perl))) ;for 'c_rehash'