summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm51
1 files changed, 42 insertions, 9 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 2a8af36ad6..d369edb8b6 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -180,7 +180,12 @@ check whether everything is alright."
(xz (->store "xz"))
(mkdir (->store "mkdir"))
(bash (->store "bash"))
- (guile (->store "guile-2.0.7.tar.xz"))
+ (guile (->store
+ (match (%current-system)
+ ("mips64el-linux"
+ "guile-2.0.9.tar.xz")
+ (_
+ "guile-2.0.7.tar.xz"))))
(builder
(add-text-to-store store
"build-bootstrap-guile.sh"
@@ -219,7 +224,11 @@ $out/bin/guile --version~%"
(origin
(method url-fetch)
(uri (map (cut string-append <> "/" system
- "/20130105/static-binaries.tar.xz")
+ (match system
+ ("mips64el-linux"
+ "/20131017/static-binaries.tar.xz")
+ (_
+ "/20130105/static-binaries.tar.xz")))
%bootstrap-base-urls))
(sha256
(match system
@@ -228,7 +237,10 @@ $out/bin/guile --version~%"
"0md23alzy6nc5f16pric7mkagczdzr8xbh074sb3rjzrls06j1ls"))
("i686-linux"
(base32
- "0nzj1lmm9b94g7k737cr4w1dv282w5nmhb53238ikax9r6pkc0yb"))))))
+ "0nzj1lmm9b94g7k737cr4w1dv282w5nmhb53238ikax9r6pkc0yb"))
+ ("mips64el-linux"
+ (base32
+ "17k5f1322b7n1difhlyw4cghxvq8fxj7wlhzghh4y362fshvvw1c"))))))
"true" ; the program to test
"Bootstrap binaries of Coreutils, Awk, etc."))
@@ -238,7 +250,11 @@ $out/bin/guile --version~%"
(origin
(method url-fetch)
(uri (map (cut string-append <> "/" system
- "/20130105/binutils-2.22.tar.xz")
+ (match system
+ ("mips64el-linux"
+ "/20131017/binutils-2.23.2.tar.xz")
+ (_
+ "/20130105/binutils-2.22.tar.xz")))
%bootstrap-base-urls))
(sha256
(match system
@@ -247,7 +263,10 @@ $out/bin/guile --version~%"
"1ffmk2yy2pxvkqgzrkzp3s4jpn4qaaksyk3b5nsc5cjwfm7qkgzh"))
("i686-linux"
(base32
- "1rafk6aq4sayvv3r3d2khn93nkyzf002xzh0xadlyci4mznr6b0a"))))))
+ "1rafk6aq4sayvv3r3d2khn93nkyzf002xzh0xadlyci4mznr6b0a"))
+ ("mips64el-linux"
+ (base32
+ "1dpnmscgg1fxg9xmlbvcm1d8h8brjgqwaal748w3v3qf33is4sl6"))))))
"ld" ; the program to test
"Bootstrap binaries of the GNU Binutils"))
@@ -289,7 +308,11 @@ $out/bin/guile --version~%"
(origin
(method url-fetch)
(uri (map (cut string-append <> "/" (%current-system)
- "/20130105/glibc-2.17.tar.xz")
+ (match (%current-system)
+ ("mips64el-linux"
+ "/20131017/glibc-2.18.tar.xz")
+ (_
+ "/20130105/glibc-2.17.tar.xz")))
%bootstrap-base-urls))
(sha256
(match (%current-system)
@@ -298,7 +321,10 @@ $out/bin/guile --version~%"
"18kv1z9d8dr1j3hm9w7663kchqw9p6rsx11n1m143jgba2jz6jy3"))
("i686-linux"
(base32
- "08hv8i0axwnihrcgbz19x0a7s6zyv3yx38x8r29liwl8h82x9g88")))))))))
+ "08hv8i0axwnihrcgbz19x0a7s6zyv3yx38x8r29liwl8h82x9g88"))
+ ("mips64el-linux"
+ (base32
+ "1w9x8r2him7qbqlm7ah1aq04kk2ydma44jzgdzsdj3kjx36sqyq1")))))))))
(synopsis "Bootstrap binaries and headers of the GNU C Library")
(description #f)
(home-page #f)
@@ -357,7 +383,11 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
(origin
(method url-fetch)
(uri (map (cut string-append <> "/" (%current-system)
- "/20130105/gcc-4.7.2.tar.xz")
+ (match (%current-system)
+ ("mips64el-linux"
+ "/20131017/gcc-4.7.3.tar.xz")
+ (_
+ "/20130105/gcc-4.7.2.tar.xz")))
%bootstrap-base-urls))
(sha256
(match (%current-system)
@@ -366,7 +396,10 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
"1x1p7han5crnbw906iwdifykr6grzm0w27dy9gz75j0q1b32i4px"))
("i686-linux"
(base32
- "06wqs0xxnpw3hn0xjb4c9cs0899p1xwkcysa2rvzhvpra0c5vsg2")))))))))
+ "06wqs0xxnpw3hn0xjb4c9cs0899p1xwkcysa2rvzhvpra0c5vsg2"))
+ ("mips64el-linux"
+ (base32
+ "0g9z8cdlnlzbg67607rxxfk5vi4xjsdc7c2agvdnyzlp0shib6rb")))))))))
(native-search-paths
(list (search-path-specification
(variable "CPATH")