summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d3b171245d..0a644e8940 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -33,7 +34,7 @@
(define-public boost
(package
(name "boost")
- (version "1.58.0")
+ (version "1.60.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -42,8 +43,7 @@
".tar.bz2"))
(sha256
(base32
- "1rfkqxns60171q62cppiyzj8pmsbwp1l8jd7p6crriryqd7j1z7x"))
- (patches (list (search-patch "boost-mips-avoid-m32.patch")))))
+ "0fzx6dwqbrkd4bcd8pjv0fpapwmrxxwr8yx9g67lihlsk3zzysk8"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
(native-inputs
@@ -63,38 +63,38 @@
;; so we disable that too.
,@(if (string-prefix? "mips64" (or (%current-target-system)
(%current-system)))
- '("--without-context" "--without-coroutine")
+ '("--without-context"
+ "--without-coroutine" "--without-coroutine2")
'()))))
`(#:tests? #f
#:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* '("libs/config/configure"
- "libs/spirit/classic/phoenix/test/runtest.sh"
- "tools/build/doc/bjam.qbk"
- "tools/build/src/engine/execunix.c"
- "tools/build/src/engine/Jambase"
- "tools/build/src/engine/jambase.c")
- (("/bin/sh") (which "sh")))
-
- (setenv "SHELL" (which "sh"))
- (setenv "CONFIG_SHELL" (which "sh"))
+ (modify-phases %standard-phases
+ (replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* '("libs/config/configure"
+ "libs/spirit/classic/phoenix/test/runtest.sh"
+ "tools/build/doc/bjam.qbk"
+ "tools/build/src/engine/execunix.c"
+ "tools/build/src/engine/Jambase"
+ "tools/build/src/engine/jambase.c")
+ (("/bin/sh") (which "sh")))
- (zero? (system* "./bootstrap.sh"
- (string-append "--prefix=" out)
- "--with-toolset=gcc"))))
- (alist-replace
- 'build
- (lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "./b2" ,@build-flags)))
+ (setenv "SHELL" (which "sh"))
+ (setenv "CONFIG_SHELL" (which "sh"))
- (alist-replace
+ (zero? (system* "./bootstrap.sh"
+ (string-append "--prefix=" out)
+ "--with-toolset=gcc")))))
+ (replace
+ 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "./b2" ,@build-flags))))
+ (replace
'install
(lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "./b2" "install" ,@build-flags)))
- %standard-phases))))))
+ (zero? (system* "./b2" "install" ,@build-flags))))))))
(home-page "http://boost.org")
(synopsis "Peer-reviewed portable C++ source libraries")