summaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 6f96e55710..fbd0425c96 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -68,16 +68,7 @@
;; Set the RUNPATH to $libdir so that the libs find each other.
(string-append "linkflags=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib")
-
- ;; Boost's 'context' library is not yet supported on mips64, so
- ;; we disable it. The 'coroutine' library depends on 'context',
- ;; so we disable that too.
- ,@(if (string-prefix? "mips64" (or (%current-target-system)
- (%current-system)))
- '("--without-context"
- "--without-coroutine" "--without-coroutine2")
- '()))
+ (assoc-ref %outputs "out") "/lib"))
#:phases
(modify-phases %standard-phases
(delete 'bootstrap)
@@ -111,12 +102,12 @@
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "./b2" "install" make-flags))))))
- (home-page "http://www.boost.org")
+ (home-page "https://www.boost.org")
(synopsis "Peer-reviewed portable C++ source libraries")
(description
"A collection of libraries intended to be widely useful, and usable
across a broad spectrum of applications.")
- (license (license:x11-style "http://www.boost.org/LICENSE_1_0.txt"
+ (license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt"
"Some components have other similar licences."))))
(define-public boost-sync
@@ -149,7 +140,7 @@ across a broad spectrum of applications.")
(description "The Boost.Sync library provides mutexes, semaphores, locks
and events and other thread related facilities. Boost.Sync originated from
Boost.Thread.")
- (license (license:x11-style "http://www.boost.org/LICENSE_1_0.txt")))))
+ (license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt")))))
(define-public mdds
(package