summaryrefslogtreecommitdiff
path: root/gnu/packages/bison.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bison.scm')
-rw-r--r--gnu/packages/bison.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/bison.scm b/gnu/packages/bison.scm
index 71de47762d..5ebc883d53 100644
--- a/gnu/packages/bison.scm
+++ b/gnu/packages/bison.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +31,7 @@
(define-public bison
(package
(name "bison")
- (version "3.0.5")
+ (version "3.4.1")
(source
(origin
(method url-fetch)
@@ -38,8 +39,17 @@
version ".tar.xz"))
(sha256
(base32
- "0f7kjygrckkx8vas2nm673592jif0a9mw5g8207f6hj6h4pfyp07"))))
+ "03c2pmq3bs0drdislnz6gm1rwz3n4pb2rz9navyxydppxg2rl597"))))
(build-system gnu-build-system)
+ (arguments
+ '(;; Building in parallel on many-core systems may cause an error such as
+ ;; "mv: cannot stat 'examples/c/reccalc/scan.stamp.tmp': No such file or
+ ;; directory". See <https://bugs.gnu.org/36238>.
+ #:parallel-build? #f
+ ;; Similarly, when building tests in parallel, Make may produce this error:
+ ;; "./examples/c/reccalc/scan.l:13:10: fatal error: parse.h: No such file
+ ;; or directory". Full log in <https://bugs.gnu.org/36238>.
+ #:parallel-tests? #f))
(native-inputs `(("perl" ,perl)
;; m4 is not present in PATH when cross-building.
("m4" ,m4)))