summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm246
1 files changed, 121 insertions, 125 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 065555b37b..0c12e7c874 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -410,7 +410,7 @@ computational cluster.")
(define-public bedtools
(package
(name "bedtools")
- (version "2.27.1")
+ (version "2.29.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/arq5x/bedtools2/releases/"
@@ -418,7 +418,7 @@ computational cluster.")
"bedtools-" version ".tar.gz"))
(sha256
(base32
- "1ndg5yknrxl4djx8ddzgk12rrbiidfpmkkg5z3f95jzryfxarhn8"))))
+ "0m3hk6548846w83a9s5drsczvy67n2azx41kj71n03klb2gbzwg3"))))
(build-system gnu-build-system)
(arguments
'(#:test-target "test"
@@ -427,7 +427,8 @@ computational cluster.")
#:phases
(modify-phases %standard-phases
(delete 'configure))))
- (native-inputs `(("python" ,python-2)))
+ (native-inputs
+ `(("python" ,python-wrapper)))
(inputs
`(("samtools" ,samtools)
("zlib" ,zlib)))
@@ -440,7 +441,7 @@ genome arithmetic: that is, set theory on the genome. For example, bedtools
allows one to intersect, merge, count, complement, and shuffle genomic
intervals from multiple files in widely-used genomic file formats such as BAM,
BED, GFF/GTF, VCF.")
- (license license:gpl2)))
+ (license license:expat)))
;; Later releases of bedtools produce files with more columns than
;; what Ribotaper expects.
@@ -2272,23 +2273,23 @@ time.")
(define-public crossmap
(package
(name "crossmap")
- (version "0.2.9")
+ (version "0.3.8")
(source (origin
(method url-fetch)
(uri (pypi-uri "CrossMap" version))
(sha256
(base32
- "1byhclrqnqpvc1rqkfh4jwj6yhn0x9y7jk47i0qcjlhk0pjkw92p"))))
+ "1sb2f2qbxya4fzw3yjl09vbrs8vfmw22zrygrvz004sf9gb1vkan"))))
(build-system python-build-system)
- (arguments `(#:python ,python-2))
(inputs
- `(("python-bx-python" ,python2-bx-python)
- ("python-numpy" ,python2-numpy)
- ("python-pysam" ,python2-pysam)
+ `(("python-bx-python" ,python-bx-python)
+ ("python-numpy" ,python-numpy)
+ ("python-pybigwig" ,python-pybigwig)
+ ("python-pysam" ,python-pysam)
("zlib" ,zlib)))
(native-inputs
- `(("python-cython" ,python2-cython)
- ("python-nose" ,python2-nose)))
+ `(("python-cython" ,python-cython)
+ ("python-nose" ,python-nose)))
(home-page "http://crossmap.sourceforge.net/")
(synopsis "Convert genome coordinates between assemblies")
(description
@@ -2578,7 +2579,7 @@ accurately delineate genomic rearrangements throughout the genome.")
(define-public diamond
(package
(name "diamond")
- (version "0.9.22")
+ (version "0.9.30")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2587,7 +2588,7 @@ accurately delineate genomic rearrangements throughout the genome.")
(file-name (git-file-name name version))
(sha256
(base32
- "0bky78v79g3wmdpsd706cscckgw1v09fg8vdd0z8z0d5b97aj9zl"))))
+ "0k6f3kb6cniw11xw6763kkbs1sl0yack7xsy7q5fl5v170ssphq4"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no "check" target
@@ -2744,7 +2745,7 @@ quantitative phenotypes.")
(define-public edirect
(package
(name "edirect")
- (version "12.1.20190819")
+ (version "12.1.20190829")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.ncbi.nlm.nih.gov/entrez/entrezdirect"
@@ -2752,7 +2753,7 @@ quantitative phenotypes.")
"/edirect-" version ".tar.gz"))
(sha256
(base32
- "1i9s9mppcfqd60pfywpm8vdyz5vpnyslw22nd7dv0bhykrdnkz9g"))))
+ "1xb330z28dgp7slrvp8r7rgncsasv9lpcpqim571yg728dq7xdik"))))
(build-system perl-build-system)
(arguments
`(#:phases
@@ -4274,19 +4275,30 @@ experiments.")
(define-public macs
(package
(name "macs")
- (version "2.1.1.20160309")
+ (version "2.2.6")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "MACS2" version))
+ ;; The PyPi tarball does not contain tests.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/taoliu/MACS.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "09ixspd1vcqmz1c81ih70xs4m7qml2iy5vyx1y74zww3iy1vl210"))))
+ "1c5gxr0mk6hkd4vclf0k00wvyvzw2vrmk52c85338p7aqjwg6n15"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2 ; only compatible with Python 2.7
- #:tests? #f)) ; no test target
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v"))))))
(inputs
- `(("python-numpy" ,python2-numpy)))
+ `(("python-numpy" ,python-numpy)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/taoliu/MACS/")
(synopsis "Model based analysis for ChIP-Seq data")
(description
@@ -4910,20 +4922,26 @@ predicts the locations of structural units in the sequences.")
(define-public proteinortho
(package
(name "proteinortho")
- (version "5.16b")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append
- "http://www.bioinf.uni-leipzig.de/Software/proteinortho/proteinortho_v"
- version "_src.tar.gz"))
- (sha256
- (base32
- "1wl0dawpssqwfjvr651r4wlww8hhjin8nba6xh71ks7sbypx886j"))))
+ (version "6.0.14")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/paulklemm_PHD/proteinortho.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pmy617zy2z2w6hjqxjhf3rzikf5n3mpia80ysq8233vfr7wrzff"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; remove pre-built scripts
+ (delete-file-recursively "src/BUILD/")
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
+ #:make-flags '("CC=gcc")
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -4941,15 +4959,23 @@ predicts the locations of structural units in the sequences.")
#t))
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((path (getenv "PATH"))
- (out (assoc-ref outputs "out"))
- (binary (string-append out "/bin/proteinortho5.pl")))
- (wrap-program binary `("PATH" ":" prefix (,path))))
+ (let ((path (getenv "PATH"))
+ (out (assoc-ref outputs "out")))
+ (for-each (lambda (script)
+ (wrap-script script `("PATH" ":" prefix (,path))))
+ (cons (string-append out "/bin/proteinortho")
+ (find-files out "\\.(pl|py)$"))))
#t)))))
(inputs
- `(("perl" ,perl)
- ("python" ,python-2)
- ("blast+" ,blast+)))
+ `(("guile" ,guile-3.0) ; for wrap-script
+ ("diamond" ,diamond)
+ ("perl" ,perl)
+ ("python" ,python-wrapper)
+ ("blast+" ,blast+)
+ ("lapack" ,lapack)
+ ("openblas" ,openblas)))
+ (native-inputs
+ `(("which" ,which)))
(home-page "http://www.bioinf.uni-leipzig.de/Software/proteinortho")
(synopsis "Detect orthologous genes across species")
(description
@@ -4957,7 +4983,7 @@ predicts the locations of structural units in the sequences.")
species. For doing so, it compares similarities of given gene sequences and
clusters them to find significant groups. The algorithm was designed to handle
large-scale data and can be applied to hundreds of species at once.")
- (license license:gpl2+)))
+ (license license:gpl3+)))
(define-public pyicoteo
(package
@@ -5281,7 +5307,7 @@ BAM and Wiggle files in both transcript-coordinate and genomic-coordinate.")
(define-public rseqc
(package
(name "rseqc")
- (version "2.6.1")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
@@ -5289,28 +5315,18 @@ BAM and Wiggle files in both transcript-coordinate and genomic-coordinate.")
(string-append "mirror://sourceforge/rseqc/"
"RSeQC-" version ".tar.gz"))
(sha256
- (base32 "15ly0254yi032qzkdplg00q144qfdsd986gh62829rl5bkxhj330"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; remove bundled copy of pysam
- (delete-file-recursively "lib/pysam")
- (substitute* "setup.py"
- ;; remove dependency on outdated "distribute" module
- (("^from distribute_setup import use_setuptools") "")
- (("^use_setuptools\\(\\)") "")
- ;; do not use bundled copy of pysam
- (("^have_pysam = False") "have_pysam = True"))
- #t))))
+ (base32
+ "0gbb9iyb7swiv5455fm5rg98r7l6qn27v564yllqjd574hncpx6m"))))
(build-system python-build-system)
- (arguments `(#:python ,python-2))
(inputs
- `(("python-cython" ,python2-cython)
- ("python-pysam" ,python2-pysam)
- ("python-numpy" ,python2-numpy)
+ `(("python-cython" ,python-cython)
+ ("python-bx-python" ,python-bx-python)
+ ("python-pybigwig" ,python-pybigwig)
+ ("python-pysam" ,python-pysam)
+ ("python-numpy" ,python-numpy)
("zlib" ,zlib)))
(native-inputs
- `(("python-nose" ,python2-nose)))
+ `(("python-nose" ,python-nose)))
(home-page "http://rseqc.sourceforge.net/")
(synopsis "RNA-seq quality control package")
(description
@@ -6556,7 +6572,7 @@ profiles, and associated taxonomic information.")
(define-public vcftools
(package
(name "vcftools")
- (version "0.1.15")
+ (version "0.1.16")
(source (origin
(method url-fetch)
(uri (string-append
@@ -6564,7 +6580,7 @@ profiles, and associated taxonomic information.")
version "/vcftools-" version ".tar.gz"))
(sha256
(base32
- "1qw30c45wihgy632rbz4rh3njnwj4msj46l1rsgdhyg6bgypmr1i"))))
+ "1qqlx7flfv7axrjwkaz6njkscsl1d0jw98ns8d8bh1n1hd1pgz6v"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target
@@ -6592,17 +6608,18 @@ data in the form of VCF files.")
(define-public infernal
(package
(name "infernal")
- (version "1.1.2")
+ (version "1.1.3")
(source (origin
(method url-fetch)
(uri (string-append "http://eddylab.org/software/infernal/"
"infernal-" version ".tar.gz"))
(sha256
(base32
- "0sr2hiz3qxfwqpz3whxr6n82p3x27336v3f34iqznp10hks2935c"))))
+ "0pm8bm3s6nfa0av4x6m6h27lsg12b3lz3jm0fyh1mc77l2isd61v"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl))) ; for tests
+ `(("perl" ,perl)
+ ("python" ,python))) ; for tests
(home-page "http://eddylab.org/infernal/")
(synopsis "Inference of RNA alignments")
(description "Infernal (\"INFERence of RNA ALignment\") is a tool for
@@ -6613,7 +6630,7 @@ profile, but it scores a combination of sequence consensus and RNA secondary
structure consensus, so in many cases, it is more capable of identifying RNA
homologs that conserve their secondary structure more than their primary
sequence.")
- ;; Infernal 1.1.2 requires VMX or SSE capability for parallel instructions.
+ ;; Infernal 1.1.3 requires VMX or SSE capability for parallel instructions.
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:bsd-3)))
@@ -6935,14 +6952,14 @@ testing and other simple calculations.")
(define-public r-shortread
(package
(name "r-shortread")
- (version "1.44.1")
+ (version "1.44.3")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "ShortRead" version))
(sha256
(base32
- "1dh3q83hmi4l72vpif6dn51dzbi9ljrjgkq2zxg4sqy2jxv4vwza"))))
+ "0ykyrj4g6vc67d5s46sp4659qvar2iavflzhggm79w4p50hxia4s"))))
(properties `((upstream-name . "ShortRead")))
(build-system r-build-system)
(inputs
@@ -7465,13 +7482,13 @@ names in their natural, rather than lexicographic, order.")
(define-public r-edger
(package
(name "r-edger")
- (version "3.28.0")
+ (version "3.28.1")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "edgeR" version))
(sha256
(base32
- "1m7l6fbyik1b79v0h9qkmpa39svij1yiw24gxahbdqjg7fzsavh3"))))
+ "07dv99kl7jfa62nzcq705r56gcpb1hq7p4px48j71y2ddi1rqmr6"))))
(properties `((upstream-name . "edgeR")))
(build-system r-build-system)
(propagated-inputs
@@ -7532,13 +7549,13 @@ coding changes and predict coding outcomes.")
(define-public r-limma
(package
(name "r-limma")
- (version "3.42.0")
+ (version "3.42.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "limma" version))
(sha256
(base32
- "0cfynv6qbnar5rl7vjh5lvddd381g9wqx1zd6a7l130hf59mwswn"))))
+ "1nd01r7rd7jb5qz84vbgfnyrmgm9wiq7fsdji68537kjgvrzmm9z"))))
(build-system r-build-system)
(home-page "http://bioinf.wehi.edu.au/limma")
(synopsis "Package for linear models for microarray and RNA-seq data")
@@ -7751,13 +7768,13 @@ biological sequences or sets of sequences.")
(define-public r-rsamtools
(package
(name "r-rsamtools")
- (version "2.2.1")
+ (version "2.2.3")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "Rsamtools" version))
(sha256
(base32
- "0hpdc88prpq1gcja89n5s1ndcg81523qrkbkm9gbhm7rm8wmi8cl"))))
+ "1vj43acawqqkf9yval9fzxarpsf04fmn78m2hq4f083w1k0myhyr"))))
(properties
`((upstream-name . "Rsamtools")))
(build-system r-build-system)
@@ -7939,13 +7956,13 @@ as well as query and modify the browser state, such as the current viewport.")
(define-public r-genomicfeatures
(package
(name "r-genomicfeatures")
- (version "1.38.1")
+ (version "1.38.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "GenomicFeatures" version))
(sha256
(base32
- "1c1x29f447dv0i1wi88paji645lfsgmg4ckn19hyhlra72smhzqc"))))
+ "0dd226kgks50jdx5w35f3wmg95hy8aibi4kcn8p5kmqp5i8j580b"))))
(properties
`((upstream-name . "GenomicFeatures")))
(build-system r-build-system)
@@ -8236,7 +8253,7 @@ throughput genetic sequencing data sets using regression methods.")
(define-public r-qtl
(package
(name "r-qtl")
- (version "1.44-9")
+ (version "1.45-11")
(source
(origin
(method url-fetch)
@@ -8244,7 +8261,7 @@ throughput genetic sequencing data sets using regression methods.")
version ".tar.gz"))
(sha256
(base32
- "03lmvydln8b7666b6w46qbryhf83vsd11d4y2v95rfgvqgq66l1i"))))
+ "1d6qgj602fm6zia3djl4hmca0ri4v57ffp3g93p2yc3cabx2hq90"))))
(build-system r-build-system)
(home-page "https://rqtl.org/")
(synopsis "R package for analyzing QTL experiments in genetics")
@@ -8332,14 +8349,14 @@ secondary structure and comparative analysis in R.")
(define-public r-rhtslib
(package
(name "r-rhtslib")
- (version "1.18.0")
+ (version "1.18.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "Rhtslib" version))
(sha256
(base32
- "04inkq44lxwymqv51mxgaphasqjcdc9rl5p58imnrdm0kszs8prm"))))
+ "0gkbrmrcg55c9s5166ifljlx0v25rv4ijdyp4wf4c292xd6chy2l"))))
(properties `((upstream-name . "Rhtslib")))
(build-system r-build-system)
;; Without this a temporary directory ends up in the Rhtslib.so binary,
@@ -9122,14 +9139,14 @@ unmodeled, or latent sources of noise.")
(define-public r-seqminer
(package
(name "r-seqminer")
- (version "7.1")
+ (version "8.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "seqminer" version))
(sha256
(base32
- "1jydcpkw4rwfp983j83kipvsvr10as9pb49zzn3c2v09k1gh3ymy"))))
+ "00jzj8mwb0zaiwlifd41b26mrq9mzigj18nc29dydi0r42hxg16i"))))
(build-system r-build-system)
(inputs
`(("zlib" ,zlib)))
@@ -9504,13 +9521,13 @@ and irregular enzymatic cleavages, mass measurement accuracy, etc.")
(define-public r-seurat
(package
(name "r-seurat")
- (version "3.1.2")
+ (version "3.1.4")
(source (origin
(method url-fetch)
(uri (cran-uri "Seurat" version))
(sha256
(base32
- "0m1qi39snbmkkv1p07bzg1r7snc9x6a1y0dghvpk1nzgcfpmnsj4"))))
+ "0lhjbjhv1hnx5i3gkx41k68i8ykay3f24708h30wx9xywww9lsvi"))))
(properties `((upstream-name . "Seurat")))
(build-system r-build-system)
(propagated-inputs
@@ -9533,6 +9550,7 @@ and irregular enzymatic cleavages, mass measurement accuracy, etc.")
("r-mass" ,r-mass)
("r-matrix" ,r-matrix)
("r-metap" ,r-metap)
+ ("r-patchwork" ,r-patchwork)
("r-pbapply" ,r-pbapply)
("r-plotly" ,r-plotly)
("r-png" ,r-png)
@@ -9549,7 +9567,6 @@ and irregular enzymatic cleavages, mass measurement accuracy, etc.")
("r-rtsne" ,r-rtsne)
("r-scales" ,r-scales)
("r-sctransform" ,r-sctransform)
- ("r-sdmtools" ,r-sdmtools)
("r-tsne" ,r-tsne)
("r-uwot" ,r-uwot)))
(home-page "http://www.satijalab.org/seurat")
@@ -10326,14 +10343,14 @@ family of feature/genome hypotheses.")
(define-public r-gviz
(package
(name "r-gviz")
- (version "1.30.1")
+ (version "1.30.3")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "Gviz" version))
(sha256
(base32
- "03jj193fzmhvkjw8f5zk6wgflkvm3phny0q38scawcplfsyb8z64"))))
+ "0c9i26h5czm60n1bxzmdxxpywcj0sig6wcj913pb41mr83bbgra3"))))
(properties `((upstream-name . "Gviz")))
(build-system r-build-system)
(propagated-inputs
@@ -10478,14 +10495,14 @@ provided.")
(define-public r-hdf5array
(package
(name "r-hdf5array")
- (version "1.14.1")
+ (version "1.14.3")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "HDF5Array" version))
(sha256
(base32
- "04hd02zd5jix5p2zg10asmwjg1fynqgmclbhbmk7fb6arx5hm11f"))))
+ "1z153a7nxmlml72pl1saasj2il9g5ahpynkpv3mkhhsvl5kbwbh6"))))
(properties `((upstream-name . "HDF5Array")))
(build-system r-build-system)
(inputs
@@ -10675,14 +10692,14 @@ quality control.")
(define-public r-scran
(package
(name "r-scran")
- (version "1.14.5")
+ (version "1.14.6")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "scran" version))
(sha256
(base32
- "0ydy6gvpgpvrs4ryk1qvmmxp6cpaizs294jwg42jawxndkds1l3y"))))
+ "1y8wlgk5zbv7c7gcp0ahfpbh9lifab7y3zwf0093fzaw7vr1y6cr"))))
(build-system r-build-system)
(propagated-inputs
`(("r-beachmat" ,r-beachmat)
@@ -11072,8 +11089,8 @@ import matplotlib
matplotlib.use('Agg')
" line)))
;; Make sure GESS has all modules in its path
- (wrap-program (string-append target "GESS.py")
- `("PYTHONPATH" ":" prefix (,target ,(getenv "PYTHONPATH"))))
+ (wrap-script (string-append target "GESS.py")
+ `("PYTHONPATH" ":" = (,target ,(getenv "PYTHONPATH"))))
(mkdir-p bin)
(symlink (string-append target "GESS.py")
(string-append bin "GESS.py"))
@@ -11084,7 +11101,8 @@ matplotlib.use('Agg')
("python2-scipy" ,python2-scipy)
("python2-numpy" ,python2-numpy)
("python2-networkx" ,python2-networkx)
- ("python2-biopython" ,python2-biopython)))
+ ("python2-biopython" ,python2-biopython)
+ ("guile" ,guile-3.0))) ; for the script wrapper
(home-page "https://compbio.uthscsa.edu/GESS_Web/")
(synopsis "Detect exon-skipping events from raw RNA-seq data")
(description
@@ -12011,23 +12029,6 @@ graphs. This library makes it easy to work with @file{.loom} files for
single-cell RNA-seq data.")
(license license:bsd-3)))
-;; pigx-scrnaseq does not work with the latest version of loompy.
-(define-public python-loompy-for-pigx-scrnaseq
- (package (inherit python-loompy)
- (name "python-loompy")
- (version "2.0.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/linnarsson-lab/loompy.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0pjyl532pl8sbv71yci6h0agchn0naw2qjcwj50n6afrsahbsag3"))))
- ;; There are none.
- (arguments '(#:tests? #f))))
-
;; We cannot use the latest commit because it requires Java 9.
(define-public java-forester
(let ((commit "86b07efe302d5094b42deed9260f719a4c4ac2e6")
@@ -12771,7 +12772,7 @@ methylation and segmentation.")
(define-public pigx-scrnaseq
(package
(name "pigx-scrnaseq")
- (version "0.0.8")
+ (version "1.1.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BIMSBbioinfo/pigx_scrnaseq/"
@@ -12779,27 +12780,21 @@ methylation and segmentation.")
"/pigx_scrnaseq-" version ".tar.gz"))
(sha256
(base32
- "0zv0sc5amivxhb95vx2gfx6l9bh7n80fh7h47dalnwxxnfvnzai4"))))
+ "0ga2jr4968qzwml6aycky4603q64lny3y7lzw6dmafch5pydl1qi"))))
(build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- (list (string-append "PICARDJAR=" (assoc-ref %build-inputs "java-picard")
- "/share/java/picard.jar")
- (string-append "DROPSEQJAR=" (assoc-ref %build-inputs "dropseq-tools")
- "/share/java/dropseq.jar"))))
(inputs
`(("coreutils" ,coreutils)
("perl" ,perl)
- ("dropseq-tools" ,dropseq-tools)
("fastqc" ,fastqc)
- ("java-picard" ,java-picard-2.10.3) ; same as for dropseq
+ ("flexbar" ,flexbar)
("java" ,icedtea-8)
+ ("jellyfish" ,jellyfish)
("python-wrapper" ,python-wrapper)
("python-pyyaml" ,python-pyyaml)
("python-pandas" ,python-pandas)
("python-magic" ,python-magic)
("python-numpy" ,python-numpy)
- ("python-loompy" ,python-loompy-for-pigx-scrnaseq)
+ ("python-loompy" ,python-loompy)
("ghc-pandoc" ,ghc-pandoc)
("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc)
("samtools" ,samtools)
@@ -12826,6 +12821,7 @@ methylation and segmentation.")
("r-rtsne" ,r-rtsne)
("r-scater" ,r-scater)
("r-scran" ,r-scran)
+ ("r-seurat" ,r-seurat)
("r-singlecellexperiment" ,r-singlecellexperiment)
("r-stringr" ,r-stringr)
("r-yaml" ,r-yaml)))
@@ -13883,7 +13879,7 @@ absolute GSEA.")
(define-public jamm
(package
(name "jamm")
- (version "1.0.7.5")
+ (version "1.0.7.6")
(source
(origin
(method git-fetch)
@@ -13893,7 +13889,7 @@ absolute GSEA.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ls889jcma1ch9h21jjhnkadgszgqj41842hhcjh6cg88f85qf3i"))))
+ "0bsa5mf9n9q5jz7mmacrra41l7r8rac5vgsn6wv1fb52ya58b970"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there are none