summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 233b7a8879..2bd71c858b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6325,6 +6325,61 @@ two-dimensional genome scans.")
libraries for systems that do not have these available via other means.")
(license license:artistic2.0)))
+(define-public r-rhtslib
+ (package
+ (name "r-rhtslib")
+ (version "1.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Rhtslib" version))
+ (sha256
+ (base32
+ "1wgpn9x8abjj7fc087pdavqc3fz0pl5xdh231mgjila18irwlhb3"))))
+ (properties `((upstream-name . "Rhtslib")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-zlibbioc" ,r-zlibbioc)))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://github.com/nhayden/Rhtslib")
+ (synopsis "High-throughput sequencing library as an R package")
+ (description
+ "This package provides the HTSlib C library for high-throughput
+nucleotide sequence analysis. The package is primarily useful to developers
+of other R packages who wish to make use of HTSlib.")
+ (license license:lgpl2.0+)))
+
+(define-public r-bamsignals
+ (package
+ (name "r-bamsignals")
+ (version "1.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "bamsignals" version))
+ (sha256
+ (base32
+ "1xqiqvg52p6fcvhr4146djbz79r3j1kmh75mq7rndwglmiybpwmy"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rhtslib" ,r-rhtslib)
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "http://bioconductor.org/packages/bamsignals")
+ (synopsis "Extract read count signals from bam files")
+ (description
+ "This package allows to efficiently obtain count vectors from indexed bam
+files. It counts the number of nucleotide sequence reads in given genomic
+ranges and it computes reads profiles and coverage profiles. It also handles
+paired-end data.")
+ (license license:gpl2+)))
+
(define-public emboss
(package
(name "emboss")