summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 31 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 313ffa11ae..bfac90ecf7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12524,7 +12524,7 @@ once. This package provides tools to perform Drop-seq analyses.")
(define-public pigx-rnaseq
(package
(name "pigx-rnaseq")
- (version "0.0.8")
+ (version "0.0.10")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BIMSBbioinfo/pigx_rnaseq/"
@@ -12532,7 +12532,7 @@ once. This package provides tools to perform Drop-seq analyses.")
"/pigx_rnaseq-" version ".tar.gz"))
(sha256
(base32
- "19nhflzs6k5c7yhi7gkwggq237cjdd1s4b4qkj5x5fkwg0rhn33i"))))
+ "0z3hr120wk2vrlmlpz1vp3n9wy3rq4y2mnzh2vf08qgqn2xfdwcw"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f ; not supported
@@ -14746,6 +14746,35 @@ vast-tools, an RNA-Seq pipeline for alternative splicing analysis. The plots
are generated using @code{ggplot2}.")
(license license:expat)))
+(define-public python-ont-fast5-api
+ (package
+ (name "python-ont-fast5-api")
+ (version "1.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nanoporetech/ont_fast5_api.git")
+ (commit (string-append "release_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03cbq4zbbwhll8ml2m9k8sa31mirsvcbjkrq1yna0kkzz9fad5fm"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-six" ,python-six)
+ ("python-h5py" ,python-h5py)
+ ("python-progressbar33" ,python-progressbar33)))
+ (home-page "https://github.com/nanoporetech/ont_fast5_api")
+ (synopsis "Interface to HDF5 files of the Oxford Nanopore fast5 file format")
+ (description
+ "This package provides a concrete implementation of the fast5 file schema
+using the generic @code{h5py} library, plain-named methods to interact with
+and reflect the fast5 file schema, and tools to convert between
+@code{multi_read} and @code{single_read} formats.")
+ (license license:mpl2.0)))
+
(define-public tbsp
(let ((commit "ec8fff4410cfb13a677dbbb95cbbc60217e64907")
(revision "1"))