summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm114
1 files changed, 92 insertions, 22 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d4380f86ac..5af4947b68 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2039,10 +2039,57 @@ normalized and standardized files, multiple visualizations can be created to
identify enrichments with functional annotations of the genome.")
(license license:gpl3+)))
+(define-public delly
+ (package
+ (name "delly")
+ (version "0.7.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tobiasrausch/delly/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0dkwy3pyxmi6dhh1lpsr3698ri5sslw9qz67hfys0bz8dgrqwabj"))
+ (patches (search-patches "delly-use-system-libraries.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests to run.
+ #:make-flags '("PARALLEL=1") ; Allow parallel execution at run-time.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda _
+ (let ((bin (string-append (assoc-ref %outputs "out") "/bin"))
+ (templates (string-append (assoc-ref %outputs "out")
+ "/share/delly/templates")))
+ (mkdir-p bin)
+ (mkdir-p templates)
+ (copy-recursively "excludeTemplates" templates)
+ (install-file "src/cov" bin)
+ (install-file "src/delly" bin)
+ (install-file "src/dpe" bin)))))))
+ (native-inputs
+ `(("python" ,python-2)))
+ (inputs
+ `(("boost" ,boost)
+ ("htslib" ,htslib)
+ ("zlib" ,zlib)
+ ("bzip2" ,bzip2)))
+ (home-page "https://github.com/tobiasrausch/delly")
+ (synopsis "Integrated structural variant prediction method")
+ (description "Delly is an integrated structural variant prediction method
+that can discover and genotype deletions, tandem duplications, inversions and
+translocations at single-nucleotide resolution in short-read massively parallel
+sequencing data. It uses paired-ends and split-reads to sensitively and
+accurately delineate genomic rearrangements throughout the genome.")
+ (license license:gpl3+)))
+
(define-public diamond
(package
(name "diamond")
- (version "0.9.18")
+ (version "0.9.19")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2051,7 +2098,7 @@ identify enrichments with functional annotations of the genome.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1vi2nddmy7knrv8gsprwqp6a40k63n3f2dfvx22ipjhrg9xir96f"))))
+ "0c4y8l90vdxmglb0w37y0413v11qzcwg8sdmy9k0c0gr3bsq7dzs"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no "check" target
@@ -3698,7 +3745,7 @@ sequencing tag position and orientation.")
(define-public mafft
(package
(name "mafft")
- (version "7.313")
+ (version "7.394")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3707,7 +3754,7 @@ sequencing tag position and orientation.")
(file-name (string-append name "-" version ".tgz"))
(sha256
(base32
- "0r83qmg2if8mi6jyx3xdf8ar2gcxl7r9nmj98jr7lxym97v61a2k"))))
+ "0bacjkxfg944p5khhyh5rd4y7wkjc9qk4v2jjj442sqlq0f8ar7b"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no automated tests, though there are tests in the read me
@@ -3784,7 +3831,7 @@ sequences).")
(define-public mash
(package
(name "mash")
- (version "1.1.1")
+ (version "2.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3793,7 +3840,7 @@ sequences).")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "08znbvqq5xknfhmpp3wcj574zvi4p7i8zifi67c9qw9a6ikp42fj"))
+ "00fx14vpmgsijwxd1xql3if934l82v8ckqgjjyyhnr36qb9qrskv"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3813,7 +3860,9 @@ sequences).")
(modify-phases %standard-phases
(add-after 'unpack 'fix-includes
(lambda _
- (substitute* '("src/mash/Sketch.cpp" "src/mash/CommandFind.cpp")
+ (substitute* '("src/mash/Sketch.cpp"
+ "src/mash/CommandFind.cpp"
+ "src/mash/CommandScreen.cpp")
(("^#include \"kseq\\.h\"")
"#include \"htslib/kseq.h\""))
#t))
@@ -10960,34 +11009,41 @@ droplet sequencing. It has been particularly tailored for Drop-seq.")
(define-public sambamba
(package
(name "sambamba")
- (version "0.6.5")
+ (version "0.6.7-10-g223fa20")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/lomereiter/sambamba/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lomereiter/sambamba.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "17076gijd65a3f07zns2gvbgahiz5lriwsa6dq353ss3jl85d8vy"))))
+ "1zb9hrxglxqh13ava9wwri30cvf85hjnbn8ccnr8l60a3k5avczn"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; there is no test target
- #:make-flags
- '("D_COMPILER=ldc2"
- ;; Override "--compiler" flag only.
- "D_FLAGS=--compiler=ldc2 -IBioD -g -d"
- "sambamba-ldmd2-64")
+ `(#:tests? #f ; there is no test target
+ #:parallel-build? #f ; not supported
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-after 'unpack 'place-biod
+ (add-after 'unpack 'fix-ldc-version
+ (lambda _
+ (substitute* "gen_ldc_version_info.py"
+ (("/usr/bin/env.*") (which "python")))
+ (substitute* "Makefile"
+ (("\\$\\(shell which ldmd2\\)") (which "ldmd2")))
+ #t))
+ (add-after 'unpack 'place-biod-and-undead
(lambda* (#:key inputs #:allow-other-keys)
(copy-recursively (assoc-ref inputs "biod") "BioD")
+ (copy-recursively (assoc-ref inputs "undead") "undeaD")
#t))
(add-after 'unpack 'unbundle-prerequisites
(lambda _
(substitute* "Makefile"
+ (("htslib/libhts.a lz4/lib/liblz4.a")
+ "-L-lhts -L-llz4")
((" htslib-static lz4-static") ""))
#t))
(replace 'install
@@ -11000,8 +11056,9 @@ droplet sequencing. It has been particularly tailored for Drop-seq.")
(native-inputs
`(("ldc" ,ldc)
("rdmd" ,rdmd)
+ ("python" ,python2-minimal)
("biod"
- ,(let ((commit "1248586b54af4bd4dfb28ebfebfc6bf012e7a587"))
+ ,(let ((commit "c778e4f2d8bacea7499283ce39f5577b232732c6"))
(origin
(method git-fetch)
(uri (git-reference
@@ -11012,7 +11069,20 @@ droplet sequencing. It has been particularly tailored for Drop-seq.")
"-checkout"))
(sha256
(base32
- "1m8hi1n7x0ri4l6s9i0x6jg4z4v94xrfdzp7mbizdipfag0m17g3")))))))
+ "1z90562hg47i63gx042wb3ak2vqjg5z7hwgn9bp2pdxfg3nxrw37")))))
+ ("undead"
+ ,(let ((commit "92803d25c88657e945511f0976a0c79d8da46e89"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlang/undeaD.git")
+ (commit commit)))
+ (file-name (string-append "undead-"
+ (string-take commit 9)
+ "-checkout"))
+ (sha256
+ (base32
+ "0vq6n81vzqvgphjw54lz2isc1j8lcxwjdbrhqz1h5gwrvw9w5138")))))))
(inputs
`(("lz4" ,lz4)
("htslib" ,htslib-for-sambamba)))