summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a6dcc63bf3..af994c6a89 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11514,7 +11514,7 @@ Browser.")
(delete 'configure)
(delete 'build)
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out")
"/bin"))
(docdir (string-append (assoc-ref outputs "out")
@@ -11537,7 +11537,16 @@ Browser.")
scripts)
(for-each (lambda (file) (install-file file docdir))
docs)
+ ;; Fix references to gunzip
+ (substitute* (map (lambda (file)
+ (string-append bin "/" file))
+ scripts)
+ (("\"gunzip -c")
+ (string-append "\"" (assoc-ref inputs "gzip")
+ "/bin/gunzip -c")))
#t))))))
+ (inputs
+ `(("gzip" ,gzip)))
(home-page "http://www.bioinformatics.babraham.ac.uk/projects/bismark/")
(synopsis "Map bisulfite treated sequence reads and analyze methylation")
(description "Bismark is a program to map bisulfite treated sequencing