summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 74646cc4a8..0c12e7c874 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11089,8 +11089,8 @@ import matplotlib
matplotlib.use('Agg')
" line)))
;; Make sure GESS has all modules in its path
- (wrap-program (string-append target "GESS.py")
- `("PYTHONPATH" ":" prefix (,target ,(getenv "PYTHONPATH"))))
+ (wrap-script (string-append target "GESS.py")
+ `("PYTHONPATH" ":" = (,target ,(getenv "PYTHONPATH"))))
(mkdir-p bin)
(symlink (string-append target "GESS.py")
(string-append bin "GESS.py"))
@@ -11101,7 +11101,8 @@ matplotlib.use('Agg')
("python2-scipy" ,python2-scipy)
("python2-numpy" ,python2-numpy)
("python2-networkx" ,python2-networkx)
- ("python2-biopython" ,python2-biopython)))
+ ("python2-biopython" ,python2-biopython)
+ ("guile" ,guile-3.0))) ; for the script wrapper
(home-page "https://compbio.uthscsa.edu/GESS_Web/")
(synopsis "Detect exon-skipping events from raw RNA-seq data")
(description