summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index beb442ebe0..616fcedc35 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11572,35 +11572,6 @@ provide this functionality without the necessity of drawing in a heavy-weight
dependency like SeqAn.")
(license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt"))))
-(define-public libdivsufsort
- (package
- (name "libdivsufsort")
- (version "2.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/y-256/libdivsufsort.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0fgdz9fzihlvjjrxy01md1bv9vh12rkgkwbm90b1hj5xpbaqp7z2"))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f ; there are no tests
- #:configure-flags
- ;; Needed for rapmap and sailfish.
- '("-DBUILD_DIVSUFSORT64=ON")))
- (home-page "https://github.com/y-256/libdivsufsort")
- (synopsis "Lightweight suffix-sorting library")
- (description "libdivsufsort is a software library that implements a
-lightweight suffix array construction algorithm. This library provides a
-simple and an efficient C API to construct a suffix array and a
-Burrows-Wheeler transformed string from a given string over a constant-size
-alphabet. The algorithm runs in O(n log n) worst-case time using only 5n+O(1)
-bytes of memory space, where n is the length of the string.")
- (license license:expat)))
-
(define-public sailfish
(package
(name "sailfish")