summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4e9397e14e..4750cb97bf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1426,15 +1426,20 @@ also includes an interface for tabix.")
(define-public python-twobitreader
(package
(name "python-twobitreader")
- (version "3.1.2")
+ (version "3.1.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "twobitreader" version))
(sha256
(base32
- "0y408fp6psqzwxpcpqn0wp7fr41dwz8d54wpj6j261fj5q8vs169"))))
+ "1q8wnj2kga9nz1lwc4w7qv52smfm536hp6mc8w6s53lhyj0mpi22"))))
(properties `((python2-variant . ,(delay python2-twobitreader))))
(build-system python-build-system)
+ (arguments
+ '(;; Tests are not distributed in the PyPi release.
+ ;; TODO Try building from the Git repo or asking the upstream maintainer
+ ;; to distribute the tests on PyPi.
+ #:tests? #f))
(native-inputs
`(("python-sphinx" ,python-sphinx)))
(home-page "https://github.com/benjschiller/twobitreader")