summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm106
1 files changed, 70 insertions, 36 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c5157046ab..5e98aea91f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3450,7 +3450,7 @@ sequences).")
(("^#include \"kseq\\.h\"")
"#include \"htslib/kseq.h\""))
#t))
- (add-before 'configure 'autoconf
+ (add-after 'fix-includes 'autoconf
(lambda _ (zero? (system* "autoconf")))))))
(native-inputs
`(("autoconf" ,autoconf)
@@ -3475,7 +3475,7 @@ form of assemblies or reads.")
(define-public metabat
(package
(name "metabat")
- (version "2.11.2")
+ (version "2.12.1")
(source
(origin
(method url-fetch)
@@ -3484,10 +3484,8 @@ form of assemblies or reads.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0rws9r1ziv6way8cf49jg8bzj7x2131kfqkhj8byf0z5hnrq3bwv"))
- (patches (search-patches "metabat-remove-compilation-date.patch"
- "metabat-fix-compilation.patch"
- "metabat-fix-boost-issue.patch"))))
+ "1hmvdalz3zj5sqqklg0l4npjdv37cv2hsdi1al9iby2ndxjs1b73"))
+ (patches (search-patches "metabat-fix-compilation.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -4065,7 +4063,7 @@ predicts the locations of structural units in the sequences.")
(define-public proteinortho
(package
(name "proteinortho")
- (version "5.16")
+ (version "5.16b")
(source
(origin
(method url-fetch)
@@ -4075,7 +4073,7 @@ predicts the locations of structural units in the sequences.")
version "_src.tar.gz"))
(sha256
(base32
- "0z4f5cg0cs8ai62hfvp4q6w66q2phcc55nhs4xj5cyhxxivjv2ai"))))
+ "1wl0dawpssqwfjvr651r4wlww8hhjin8nba6xh71ks7sbypx886j"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -4751,6 +4749,13 @@ simultaneously.")
#:tests? #f ; no "check" target
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'set-perl-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) "/setup:"
+ (getenv "PERL5LIB")))
+ #t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -5056,6 +5061,13 @@ sequence itself can be retrieved from these databases.")
"/lib32")))
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'set-perl-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) "/setup:"
+ (getenv "PERL5LIB")))
+ #t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
;; The build system expects a directory containing the sources and
@@ -5396,7 +5408,7 @@ application of SortMeRNA is filtering rRNA from metatranscriptomic data.")
#t))
(delete 'configure))))
(native-inputs
- `(("vim" ,vim))) ; for xxd
+ `(("xxd" ,xxd)))
(inputs
`(("htslib" ,htslib)
("zlib" ,zlib)))
@@ -5654,18 +5666,17 @@ information as possible.")
(define-public r-vegan
(package
(name "r-vegan")
- (version "2.4-3")
+ (version "2.4-4")
(source
(origin
(method url-fetch)
(uri (cran-uri "vegan" version))
(sha256
(base32
- "15zcxfix2d854897k1lr0sfmj2n00339nlsppcr3zrb238lb2mi5"))))
+ "1n57dzv2aid6iqd9fkqik401sidqanhzsawyak94qbiyh6dbd1x9"))))
(build-system r-build-system)
(native-inputs
- `(("gfortran" ,gfortran)
- ("r-knitr" ,r-knitr)))
+ `(("gfortran" ,gfortran)))
(propagated-inputs
`(("r-cluster" ,r-cluster)
("r-lattice" ,r-lattice)
@@ -6126,10 +6137,33 @@ data. It is derived from the UCSC hg19 genome and based on the \"knownGene\"
track. The database is exposed as a @code{TxDb} object.")
(license license:artistic2.0)))
+(define-public r-sparql
+ (package
+ (name "r-sparql")
+ (version "1.16")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "SPARQL" version))
+ (sha256
+ (base32
+ "0gak1q06yyhdmcxb2n3v0h9gr1vqd0viqji52wpw211qp6r6dcrc"))))
+ (properties `((upstream-name . "SPARQL")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcurl" ,r-rcurl)
+ ("r-xml" ,r-xml)))
+ (home-page "http://cran.r-project.org/web/packages/SPARQL")
+ (synopsis "SPARQL client for R")
+ (description "This package provides an interface to use SPARQL to pose
+SELECT or UPDATE queries to an end-point.")
+ ;; The only license indication is found in the DESCRIPTION file,
+ ;; which states GPL-3. So we cannot assume GPLv3+.
+ (license license:gpl3)))
+
(define-public vsearch
(package
(name "vsearch")
- (version "2.4.3")
+ (version "2.4.4")
(source
(origin
(method url-fetch)
@@ -6139,7 +6173,7 @@ track. The database is exposed as a @code{TxDb} object.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0hc110ycqpa54nr6x173qg7190hk08qp7yz7zzqxlsypqnpc5zzp"))
+ "1d8a4gjwaqdv57krlr80x18mg5py1bbdiqs5m0jdn38filc9z40k"))
(patches (search-patches "vsearch-unbundle-cityhash.patch"))
(snippet
'(begin
@@ -6153,8 +6187,8 @@ track. The database is exposed as a @code{TxDb} object.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autogen
- (lambda _ (zero? (system* "autoreconf" "-vif")))))))
+ (add-after 'unpack 'autogen
+ (lambda _ (zero? (system* "autoreconf" "-vif")))))))
(inputs
`(("zlib" ,zlib)
("bzip2" ,bzip2)
@@ -6433,13 +6467,13 @@ also known as views, in a controlled vocabulary.")
(define-public r-bookdown
(package
(name "r-bookdown")
- (version "0.4")
+ (version "0.5")
(source (origin
(method url-fetch)
(uri (cran-uri "bookdown" version))
(sha256
(base32
- "1fp1k7hivrb7s2dwgrsqy9s7xg6pk9hczhrc149y1dwh901j6qvv"))))
+ "0zm63kr4f4kja4qpwkzl119zzyciqj7ihajfqgfjpgb4dzaiycxp"))))
(build-system r-build-system)
(propagated-inputs
`(("r-htmltools" ,r-htmltools)
@@ -7109,13 +7143,13 @@ samples.")
(define-public r-genomicalignments
(package
(name "r-genomicalignments")
- (version "1.12.1")
+ (version "1.12.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "GenomicAlignments" version))
(sha256
(base32
- "127690sys4i5q3l4vxnjg4xg8q19qlw2258vgs5d1156w9ypp04h"))))
+ "03ysxi9fdd3bcfj05iaysya9knn2aa2irwpypb5srg0xwv92bdb9"))))
(properties
`((upstream-name . "GenomicAlignments")))
(build-system r-build-system)
@@ -7990,7 +8024,7 @@ paired-end data.")
(define-public r-rcas
(package
(name "r-rcas")
- (version "1.1.1")
+ (version "1.3.4")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BIMSBbioinfo/RCAS/archive/v"
@@ -7998,7 +8032,7 @@ paired-end data.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1hd0r66556bxbdd82ksjklq7nfli36l4k6y88ic7kkg9873wa1nw"))))
+ "1qgc7vi6fpzl440yg7jhiycg5q336kd4pxqzx10yx2zcq3bq3msg"))))
(build-system r-build-system)
(native-inputs
`(("r-knitr" ,r-knitr)
@@ -8019,6 +8053,7 @@ paired-end data.")
("r-bsgenome-dmelanogaster-ucsc-dm3" ,r-bsgenome-dmelanogaster-ucsc-dm3)
("r-topgo" ,r-topgo)
("r-dt" ,r-dt)
+ ("r-pbapply" ,r-pbapply)
("r-plotly" ,r-plotly)
("r-plotrix" ,r-plotrix)
("r-motifrg" ,r-motifrg)
@@ -8032,7 +8067,7 @@ paired-end data.")
intuitive reports and publication-ready graphics. This package provides the R
library implementing most of the pipeline's features.")
(home-page "https://github.com/BIMSBbioinfo/RCAS")
- (license license:expat)))
+ (license license:artistic2.0)))
(define-public rcas-web
(package
@@ -8370,14 +8405,14 @@ used by @code{ensembldb}, @code{Organism.dplyr}, and other packages.")
AC_DEFINE([PLD_png], [1], [Define to 1 if PNG support is available])
AM_CONDITIONAL(AMPNG, true)"))
#t))
- (add-after 'unpack 'disable-update-check
+ (add-after 'fix-checks 'disable-update-check
(lambda _
;; At build time there is no connection to the Internet, so
;; looking for updates will not work.
(substitute* "Makefile.am"
(("\\$\\(bindir\\)/embossupdate") ""))
#t))
- (add-before 'configure 'autogen
+ (add-after 'disable-update-check 'autogen
(lambda _ (zero? (system* "autoreconf" "-vif")))))))
(inputs
`(("perl" ,perl)
@@ -8575,25 +8610,24 @@ replacement for strverscmp.")
(define-public multiqc
(package
(name "multiqc")
- (version "0.9")
+ (version "1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "multiqc" version))
(sha256
(base32
- "12gs1jw2jrxrij529rnl5kaqxfcqn15yzcsggxkfhdx634ml0cny"))
- (patches (search-patches "multiqc-fix-git-subprocess-error.patch"))))
+ "032svgym67k2ds7wp0cxzv79gi30yrdl45zbqn74lni3dk04qm33"))))
(build-system python-build-system)
- (arguments
- ;; Tests are to be introduced in the next version, see
- ;; https://github.com/ewels/MultiQC/issues/376
- `(#:tests? #f))
(propagated-inputs
`(("python-jinja2" ,python-jinja2)
("python-simplejson" ,python-simplejson)
("python-pyyaml" ,python-pyyaml)
("python-click" ,python-click)
+ ("python-spectra" ,python-spectra)
+ ("python-requests" ,python-requests)
+ ("python-markdown" ,python-markdown)
+ ("python-lzstring" ,python-lzstring)
("python-matplotlib" ,python-matplotlib)
("python-numpy" ,python-numpy)
;; MultQC checks for the presence of nose at runtime.
@@ -8830,14 +8864,14 @@ trait.")
(define-public r-maldiquant
(package
(name "r-maldiquant")
- (version "1.16.2")
+ (version "1.16.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "MALDIquant" version))
(sha256
(base32
- "0z5srzsfgsgi4bssr4chls4ry6d18y2g9143znqmraylppwrrqzr"))))
+ "1pmhsfvd45a44xdiml4zx3zd5fhygqyziqvygahkk9yibnyhv4cv"))))
(properties `((upstream-name . "MALDIquant")))
(build-system r-build-system)
(home-page "http://cran.r-project.org/web/packages/MALDIquant")
@@ -9443,7 +9477,7 @@ problems in genomics, brain imaging, astrophysics, and data mining.")
(substitute-keyword-arguments (package-arguments htslib)
((#:phases phases)
`(modify-phases ,phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-vif"))))))))
(native-inputs