summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm89
1 files changed, 89 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7b0405427c..2187572117 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -832,6 +833,36 @@ Disease Ontology.")
using data from public repositories.")
(license license:artistic2.0)))
+(define-public r-phastcons100way-ucsc-hg19
+ (package
+ (name "r-phastcons100way-ucsc-hg19")
+ (version "3.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "phastCons100way.UCSC.hg19"
+ version 'annotation))
+ (sha256
+ (base32
+ "1jmc4k4zgkx5vr2plnidnd9bidlwlb0kr7mjg60cqjw7dq7jl1fa"))))
+ (properties
+ `((upstream-name . "phastCons100way.UCSC.hg19")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bsgenome" ,r-bsgenome)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-genomicscores" ,r-genomicscores)
+ ("r-iranges" ,r-iranges)
+ ("r-s4vectors" ,r-s4vectors)))
+ (home-page "https://bioconductor.org/packages/phastCons100way.UCSC.hg19")
+ (synopsis "UCSC phastCons conservation scores for hg19")
+ (description
+ "This package provides UCSC phastCons conservation scores for the human
+genome (hg19) calculated from multiple alignments with other 99 vertebrate
+species.")
+ (license license:artistic2.0)))
+
;;; Experiment data
@@ -6048,3 +6079,61 @@ attributable to individual, tissue, time point, or technical variables. The
package includes dream differential expression analysis for repeated
measures.")
(license license:gpl2+)))
+
+(define-public r-htqpcr
+ (package
+ (name "r-htqpcr")
+ (version "1.38.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "HTqPCR" version))
+ (sha256
+ (base32
+ "09xgj797f0qsbm4jswxw7ijjwa4jxg06bfkq66xfhbvascyyrhg7"))))
+ (properties `((upstream-name . "HTqPCR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-affy" ,r-affy)
+ ("r-biobase" ,r-biobase)
+ ("r-gplots" ,r-gplots)
+ ("r-limma" ,r-limma)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)))
+ (home-page "http://www.ebi.ac.uk/bertone/software")
+ (synopsis "Automated analysis of high-throughput qPCR data")
+ (description
+ "Analysis of Ct values from high throughput quantitative real-time
+PCR (qPCR) assays across multiple conditions or replicates. The input data
+can be from spatially-defined formats such ABI TaqMan Low Density Arrays or
+OpenArray; LightCycler from Roche Applied Science; the CFX plates from Bio-Rad
+Laboratories; conventional 96- or 384-well plates; or microfluidic devices
+such as the Dynamic Arrays from Fluidigm Corporation. HTqPCR handles data
+loading, quality assessment, normalization, visualization and parametric or
+non-parametric testing for statistical significance in Ct values between
+features (e.g. genes, microRNAs).")
+ (license license:artistic2.0)))
+
+(define-public r-unifiedwmwqpcr
+ (package
+ (name "r-unifiedwmwqpcr")
+ (version "1.20.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "unifiedWMWqPCR" version))
+ (sha256
+ (base32
+ "10j70bp5y1x2prz2iagqmwf04y79yqinq08wz4ilh8wggb9f7l8a"))))
+ (properties
+ `((upstream-name . "unifiedWMWqPCR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-htqpcr" ,r-htqpcr)))
+ (home-page "https://bioconductor.org/packages/unifiedWMWqPCR")
+ (synopsis "Unified Wilcoxon-Mann Whitney Test for differential expression in qPCR data")
+ (description
+ "This packages implements the unified Wilcoxon-Mann-Whitney Test for qPCR
+data. This modified test allows for testing differential expression in qPCR
+data.")
+ (license license:gpl2+)))