summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 0923f5d55a..96ebe991e4 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
@@ -171,6 +171,13 @@ number/base32-hash tuples, directly usable in the 'patch-series' form."
(rename-file (string-append out "/lib/pkgconfig")
(string-append include
"/lib/pkgconfig"))
+
+ ;; Don't capture the absolute file name of 'install' to avoid
+ ;; retaining a dependency on Coreutils.
+ (substitute* (string-append (lib include)
+ "/Makefile.inc")
+ (("^INSTALL =.*")
+ "INSTALL = install -c\n"))
#t))))))
(native-search-paths