summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 7147baeb0a..e0f2844bce 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -392,6 +392,7 @@ change. GNU make offers many powerful extensions over the standard utility.")
(define-public binutils
(package
+ (replacement binutils/fixed)
(name "binutils")
(version "2.28")
(source (origin
@@ -433,6 +434,19 @@ included.")
(license gpl3+)
(home-page "https://www.gnu.org/software/binutils/")))
+(define binutils/fixed
+ (package
+ (inherit binutils)
+ ;; 2.28.1 is two characters longer than 2.28, so grafting fails due to
+ ;; mismatched lengths of filenames, so we have to force it to the same length.
+ (version "2281")
+ (source
+ (origin (inherit (package-source binutils))
+ (uri "mirror://gnu/binutils/binutils-2.28.1.tar.bz2")
+ (sha256
+ (base32
+ "1sj234nd05cdgga1r36zalvvdkvpfbr12g5mir2n8i1dwsdrj939"))))))
+
(define* (make-ld-wrapper name #:key
(target (const #f))
binutils