summaryrefslogtreecommitdiff
path: root/gnu/packages/avahi.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/avahi.scm')
-rw-r--r--gnu/packages/avahi.scm46
1 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index ba609cf12e..602f9d7997 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,17 +26,18 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages libdaemon)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages glib)
#:use-module (gnu packages xml))
(define-public avahi
(package
(name "avahi")
- (version "0.7")
- (replacement avahi/fixed)
+ (version "0.8")
(home-page "https://avahi.org")
(source (origin
(method url-fetch)
@@ -43,29 +45,40 @@
version ".tar.gz"))
(sha256
(base32
- "0128n7jlshw4bpx0vg8lwj8qwdisjxi7mvniwfafgnkzzrfrpaap"))
- (patches (search-patches "avahi-localstatedir.patch"))))
+ "1npdixwxxn3s9q1f365x9n9rc5xgfz39hxf23faqvlrklgbhj0q6"))
+ (patches (search-patches "avahi-localstatedir.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Fix version constraint in the avahi-libevent pkg-config file.
+ ;; This can be removed for Avahi versions > 0.8.
+ (substitute* "avahi-libevent.pc.in"
+ (("libevent-2\\.1\\.5")
+ "libevent >= 2.1.5"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-distro=none"
+ "--disable-static"
"--localstatedir=/var" ; for the DBus socket
"--disable-python"
"--disable-mono"
"--disable-doxygen-doc"
"--disable-xmltoman"
"--enable-tests"
- "--disable-qt3" "--disable-qt4"
+ "--disable-qt4" "--disable-qt5"
"--disable-gtk" "--disable-gtk3"
"--enable-compat-libdns_sd")))
(inputs
- `(("expat" ,expat)
- ("glib" ,glib)
- ("dbus" ,dbus)
+ `(("dbus" ,dbus)
+ ("expat" ,expat)
("gdbm" ,gdbm)
+ ("glib" ,glib)
("libcap" ,libcap) ;to enable chroot support in avahi-daemon
- ("libdaemon" ,libdaemon)))
+ ("libdaemon" ,libdaemon)
+ ("libevent" ,libevent)))
(native-inputs
- `(("intltool" ,intltool)
+ `(("gettext" ,gettext-minimal)
("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(synopsis "Implementation of mDNS/DNS-SD protocols")
@@ -75,17 +88,6 @@ network. It is an implementation of the mDNS (for \"Multicast DNS\") and
DNS-SD (for \"DNS-Based Service Discovery\") protocols.")
(license lgpl2.1+)))
-(define avahi/fixed
- (package
- (inherit avahi)
- (source (origin
- (inherit (package-source avahi))
- (patches
- (append (search-patches "avahi-CVE-2018-1000845.patch")
- (origin-patches (package-source avahi))))))
- ;; Hide a duplicate of the CVE fixed above.
- (properties `((lint-hidden-cve . ("CVE-2017-6519"))))))
-
(define-public nss-mdns
(package
(name "nss-mdns")