summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index df1202087c..83fde34325 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -285,14 +285,15 @@ engineers, musicians, soundtrack editors and composers.")
(define-public audacity
(package
(name "audacity")
- (version "2.2.1")
+ (version "2.2.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/audacity/audacity/archive"
"/Audacity-" version ".tar.gz"))
(sha256
- (base32 "1n05r8b4rnf9fas0py0is8cm97s3h65dgvqkk040aym5d1x6wd7z"))
+ (base32
+ "18q7i77ynihx7xp45lz2lv0k0wrh6736pcrivlpwrxjgbvyqx7km"))
(patches (search-patches "audacity-build-with-system-portaudio.patch"))
(modules '((guix build utils)))
(snippet
@@ -555,7 +556,7 @@ based on human speech recordings.")
(define-public infamous-plugins
(package
(name "infamous-plugins")
- (version "0.2.02")
+ (version "0.2.04")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ssj71/infamousPlugins/"
@@ -563,10 +564,10 @@ based on human speech recordings.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0qm3ak07vc1l3f5c3c2lq9gkfknlxwn8ks03cysw1pk8hj7dwnv6"))))
+ "1n6rhqsmvad7692w2h01niw5gqg5yk7a09wxl5ivs77zyp93vf7z"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; There are no tests
+ `(#:tests? #f ; there are no tests
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'remove-compiler-flags
@@ -581,7 +582,7 @@ based on human speech recordings.")
"src/powercut/CMakeLists.txt"
"src/powerup/CMakeLists.txt"
"src/stuck/CMakeLists.txt")
- (("-msse2 -mfpmath=sse") ""))
+ (("-msse2 -mfpmath=sse") ""))
#t)))))
(inputs
`(("cairo" ,cairo)
@@ -591,7 +592,7 @@ based on human speech recordings.")
("zita-resampler" ,zita-resampler)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://ssj71.github.io/infamousPlugins")
+ (home-page "https://ssj71.github.io/infamousPlugins")
(synopsis "LV2 plugins for live use")
(description
"The infamous plugins are a collection of LV2 audio plugins for live