summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 49ec474ffd..88f3b5eccd 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1109,7 +1109,7 @@ follower.")
(define-public fluidsynth
(package
(name "fluidsynth")
- (version "2.0.6")
+ (version "2.0.7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1118,7 +1118,7 @@ follower.")
(file-name (git-file-name name version))
(sha256
(base32
- "0nas9pp9r8rnziznxm65x2yzf1ryg98zr3946g0br3s38sjf8l3a"))))
+ "1h1dj3wmjwzny2hgr41k3p67w4kxvzn365kkqwyfd6yk0v3rahic"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no check target
@@ -2771,22 +2771,14 @@ conversion. It may be used, for example, to resample PCM-encoded audio.")
(define-public twolame
(package
(name "twolame")
- (version "0.3.13")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/twolame/twolame/" version
"/twolame-" version ".tar.gz"))
(sha256
- (base32 "0ahiqqng5pidwhj1wzph4vxxgxxgcfa3gl0gywipzx2ii7s35wwq"))
- (modules '((guix build utils)))
- ;; The tests break with Perl 5.24:
- ;; https://github.com/njh/twolame/issues/21
- ;; TODO: Remove this snippet when upgrading twolame.
- (snippet
- '(begin
- (substitute* "tests/test.pl" (("\\(@_\\)") "($_[0])"))
- #t))))
+ (base32 "0zf8sxqb02w07ah55b1y7ab643zmpbhn62spa9pqra0rc17l4dfc"))))
(build-system gnu-build-system)
(inputs
`(("libsndfile" ,libsndfile)))