summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm29
1 files changed, 23 insertions, 6 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8ec69d12a7..b664712f7a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1041,7 +1042,7 @@ follower.")
(define-public fluidsynth
(package
(name "fluidsynth")
- (version "1.1.11")
+ (version "2.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1050,7 +1051,7 @@ follower.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0n75jq3xgq46hfmjkaaxz3gic77shs4fzajq40c8gk043i84xbdh"))))
+ "1mqyym5qkh8xd1rqj3yhfxbw5dxjcrljb6nkfqzvcarlv4h6rjn7"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no check target
@@ -1082,6 +1083,22 @@ device. It is the software analogue of a MIDI synthesizer. FluidSynth can
also play midifiles using a Soundfont.")
(license license:lgpl2.1+)))
+;; gzdoom@3.3.0 and lmms@1.1.3 requires this version. Remove once no longer
+;; needed.
+(define-public fluidsynth-1
+ (package
+ (inherit fluidsynth)
+ (version "1.1.11")
+ (source (origin
+ (inherit (package-source fluidsynth))
+ (uri (git-reference
+ (url "https://github.com/FluidSynth/fluidsynth")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "fluidsynth" version))
+ (sha256
+ (base32
+ "0n75jq3xgq46hfmjkaaxz3gic77shs4fzajq40c8gk043i84xbdh"))))))
+
(define-public faad2
(package
(name "faad2")
@@ -1912,7 +1929,7 @@ lv2-c++-tools.")
(define-public openal
(package
(name "openal")
- (version "1.19.0")
+ (version "1.19.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1920,7 +1937,7 @@ lv2-c++-tools.")
version ".tar.bz2"))
(sha256
(base32
- "1mhf5bsb58s1xk6hvxl7ly7rd4rpl9z8h07xl1q94brywykg7bgi"))))
+ "1sdjhkz2gd6lbnwphi1b6aw3br4wv2lik5vnqh6mxfc8a7zqfbsw"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -2761,7 +2778,7 @@ interface.")
(define-public qsynth
(package
(name "qsynth")
- (version "0.5.2")
+ (version "0.5.3")
(source
(origin
(method url-fetch)
@@ -2769,7 +2786,7 @@ interface.")
"/qsynth-" version ".tar.gz"))
(sha256
(base32
- "1rfkaxq1pyc4hv3l0i6wicianbcbm1wp53kh9i5d4jsljgisd1dv"))))
+ "1jghczmmva7cyavg1q0j8nr3hmjpzzglzi5ckg92ax4ji8gpks9c"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" phase