summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2aa65d5880..879c6ba6a6 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -117,7 +117,7 @@ programs for the manipulation and analysis of astronomical data.")
(define-public stellarium
(package
(name "stellarium")
- (version "0.15.1")
+ (version "0.15.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/stellarium/"
@@ -125,7 +125,7 @@ programs for the manipulation and analysis of astronomical data.")
version "/stellarium-" version ".tar.gz"))
(sha256
(base32
- "04avigz8i8mi2x6x71bqr9np85n1p9qnvbj2hxr947f1jv22zr8g"))))
+ "19nxj482g1hh9qicgskpcgy61pri254jgxnkd10icxbnza4c0hv9"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
@@ -141,6 +141,14 @@ programs for the manipulation and analysis of astronomical data.")
(arguments
`(#:test-target "tests"
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-version-check
+ (lambda _
+ ;; Previously-deprecated cmake variable vanished in
+ ;; Qt 5.9.
+ ;; See <https://bugreports.qt.io/browse/QTBUG-60936>.
+ (substitute* "CMakeLists.txt"
+ (("Qt5Core_VERSION_STRING") "Qt5Core_VERSION"))
+ #t))
(add-before 'check 'set-offscreen-display
(lambda _
;; make Qt render "offscreen", required for tests