summaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm40
1 files changed, 29 insertions, 11 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index f39205714c..188e91d1e1 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Christopher Andersson <christopher@8bits.nu>
+;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -65,7 +66,8 @@ dictionaries, including personal ones.")
;;;
;;; Dictionaries.
;;;
-;;; Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use them.
+;;; Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use
+;;; them.
;;;
(define* (aspell-dictionary dict-name full-name
@@ -81,16 +83,17 @@ dictionaries, including personal ones.")
(sha256 sha256)))
(build-system gnu-build-system)
(arguments
- `(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure"))))
- %standard-phases)
- #:make-flags (let ((out (assoc-ref %outputs "out")))
- (list (string-append "dictdir=" out "/lib/aspell")
- (string-append "datadir=" out "/lib/aspell")))
- #:tests? #f))
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./configure"))))))
+ #:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "dictdir=" out "/lib/aspell")
+ (string-append "datadir=" out "/lib/aspell")))
+ #:tests? #f))
(native-inputs `(("aspell" ,aspell)
("which" ,which)))
(synopsis (string-append full-name " dictionary for GNU Aspell")) ; XXX: i18n
@@ -172,3 +175,18 @@ dictionaries, including personal ones.")
#:sha256
(base32
"02jwkjhr32kvyibnyzgx3smbnm576jwdzg3avdf6zxwckhy5fw4v")))
+
+(define-public aspell-dict-el
+ (aspell-dictionary "el" "Greek"
+ #:version "0.08-0"
+ #:prefix "aspell6-"
+ #:sha256
+ (base32
+ "1ljcc30zg2v2h3w5h5jr5im41mw8jbsgvvhdd2cii2yzi8d0zxja")))
+
+(define-public aspell-dict-grc
+ (aspell-dictionary "grc" "Ancient Greek"
+ #:version "0.02-0"
+ #:sha256
+ (base32
+ "1zxr8958v37v260fkqd4pg37ns5h5kyqm54hn1hg70wq5cz8h512")))