summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9392c59521..c6ed4c6d4a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -438,7 +438,7 @@ hostname.")
(define-public shadow
(package
(name "shadow")
- (version "4.6")
+ (version "4.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -446,7 +446,7 @@ hostname.")
"download/" version "/shadow-" version ".tar.xz"))
(sha256
(base32
- "10smy01km2bqjjvsd2jz17zvrxbzj89qczyb1amk38j28bcci609"))))
+ "0v71474rx38lg9kidrm4xbk35sg3icv3s5pk2b42icp3lyj9dqg5"))))
(build-system gnu-build-system)
(arguments
`(;; Assume System V `setpgrp (void)', which is the default on GNU
@@ -482,7 +482,7 @@ hostname.")
"-linux")
`(("linux-pam" ,linux-pam))
'()))
- (home-page "http://pkg-shadow.alioth.debian.org/")
+ (home-page "https://github.com/shadow-maint/shadow")
(synopsis "Authentication-related tools such as passwd, su, and login")
(description
"Shadow provides a number of authentication-related tools, including:
@@ -1734,13 +1734,13 @@ of supported upstream metrics systems simultaneously.")
(define-public ansible
(package
(name "ansible")
- (version "2.8.0")
+ (version "2.8.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible" version))
(sha256
- (base32 "1bpk5r5x6vdgn839n74yv2chd2ja10yfrhav0fzwa38mi5yxsd3j"))))
+ (base32 "0ia4x17ywym3r1m96ar4h0wc2xlylhbjp6x4wzwkh4p2i0x1vmg1"))))
(build-system python-build-system)
(native-inputs
`(("python-bcrypt" ,python-bcrypt)
@@ -2133,7 +2133,9 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
(commit (string-append "v" version))))
(file-name (git-file-name "dstat" version))
(sha256
- (base32 "1qnmkhqmjd1m3if05jj29dvr5hn6kayq9bkkkh881w472c0zhp8v"))))
+ (base32 "1qnmkhqmjd1m3if05jj29dvr5hn6kayq9bkkkh881w472c0zhp8v"))
+ (patches (search-patches "dstat-fix-crash-when-specifying-delay.patch"
+ "dstat-skip-devices-without-io.patch"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no make check
@@ -2142,6 +2144,11 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
"prefix=/"))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-python3-DeprecationWarning
+ (lambda _
+ (substitute* "dstat"
+ (("collections") "collections.abc"))
+ #t))
(delete 'configure) ; no configure script
(add-after 'install 'wrap
(lambda* (#:key outputs #:allow-other-keys)
@@ -2150,8 +2157,6 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
`("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))
#t))))))
(inputs
- ;; Python 3 is supposedly supported but prints a DeprecationWarning.
- ;; Upstream is dead. See <https://github.com/dagwieers/dstat/releases>.
`(("python" ,python-wrapper)
("python-six" ,python-six)))
(synopsis "Versatile resource statistics tool")