summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm101
1 files changed, 97 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8f4a4cd41e..ef7bff10f3 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
+;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -84,14 +85,14 @@
(define-public aide
(package
(name "aide")
- (version "0.15.1")
+ (version "0.16")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/aide/aide/"
version "/aide-" version ".tar.gz"))
(sha256
(base32
- "1vsrc0s62kv1i84skm6k6zy868gayjck268qwj38rpspc8c5qgih"))))
+ "0ibkv4z2gk14fn014kq13rp2ysiq6nn2cflv2q5i7zf466hm6758"))))
(build-system gnu-build-system)
(native-inputs
`(("bison" ,bison)
@@ -100,6 +101,7 @@
`(("libgcrypt" ,libgcrypt)
("libgpg-error" ,libgpg-error)
("libmhash" ,libmhash)
+ ("pcre" ,pcre)
("zlib" ,zlib)))
(synopsis "File and directory integrity checker")
(description
@@ -1352,14 +1354,14 @@ of supported upstream metrics systems simultaneously.")
(define-public ansible
(package
(name "ansible")
- (version "2.2.1.0")
+ (version "2.3.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible" version))
(sha256
(base32
- "0gz9i30pdmkchi936ijy873k8di6fmf3v5rv551hxyf0hjkjx8b3"))))
+ "0n54h8g6a6hcp41sasvjqa4yz1pwd8mshbwlcghj0sjnrl3kk7r9"))))
(build-system python-build-system)
(native-inputs
`(("python2-pycrypto" ,python2-pycrypto)
@@ -2087,3 +2089,94 @@ It is similar to Capistrano, except it's implemented in Python and doesn't
expect you to be deploying Rails applications. Fabric is a simple, Pythonic
tool for remote execution and deployment.")
(license license:bsd-2)))
+
+(define-public neofetch
+ (package
+ (name "neofetch")
+ (version "3.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dylanaraps/neofetch/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rgznkl7a5q7lnc6zxlwvinq20b7k46n949l1hiwifarv0jgwynv"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; there are no tests
+ #:make-flags
+ (list (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-target-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("\\$\\(DESTDIR\\)/etc/")
+ "$(PREFIX)/etc/"))
+ (substitute* "neofetch"
+ (("\"/etc/neofetch")
+ (string-append "\"" out "/etc/neofetch"))
+ (("\"/usr/share/neofetch")
+ (string-append "\"" out "/usr/share/neofetch"))))
+ #t))
+ (delete 'configure))))
+ (home-page "https://github.com/dylanaraps/neofetch")
+ (synopsis "System info script")
+ (description "Neofetch is a CLI system information tool written in Bash.
+Neofetch displays information about your system next to an image, your OS
+logo, or any ASCII file of your choice. The main purpose of Neofetch is to be
+used in screenshots to show other users what operating system or distribution
+you are running, what theme or icon set you are using, etc.")
+ (license license:expat)))
+
+(define-public nnn
+ (package
+ (name "nnn")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/jarun/nnn/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hww4385f81lyy30fx2rb4wchfi79dpgl7yylnfxvf27a4h2mkhm"))))
+ (build-system gnu-build-system)
+ (inputs `(("ncurses" ,ncurses)
+ ("readline" ,readline)))
+ (arguments
+ '(#:tests? #f ; no tests
+ #:phases
+ ;; We do not provide `ncurses.h' within an `ncursesw'
+ ;; sub-directory, so patch the source accordingly. See
+ ;; <http://bugs.gnu.org/19018>.
+ ;; Thanks to gtypist maintainer.
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-curses-lib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("-lncursesw")
+ "-lncurses"))
+ (substitute* "nnn.c"
+ (("ncursesw\\/curses.h")
+ "ncurses.h")))
+ #t))
+ (delete 'configure))
+ #:make-flags
+ (list
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ (string-append "-Wl,-rpath="
+ %output "/lib")
+ "CC=gcc")))
+ (home-page "https://github.com/jarun/nnn")
+ (synopsis "Terminal file browser")
+ (description "@command{nnn} is a fork of @command{noice}, a blazing-fast
+lightweight terminal file browser with easy keyboard shortcuts for
+navigation, opening files and running tasks. There is no config file and
+mime associations are hard-coded. The incredible user-friendliness and speed
+make it a perfect utility on modern distros.")
+ (license license:bsd-2)))