summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm26
1 files changed, 22 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index bc8dc48f0e..cb5e86d39a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -783,6 +783,11 @@ over ssh connections.")
"/etc"))
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda _
+ (substitute* "rc/rc"
+ (("/usr/sbin/sendmail") "sendmail"))
+ #t))
(add-after 'build 'set-packdir
(lambda _
;; Set a default location for archived logs.
@@ -902,6 +907,11 @@ commands and their arguments.")
"http://w1.fi/releases/wpa_supplicant-"
version
".tar.gz"))
+ (patches (search-patches "wpa-supplicant-CVE-2017-13082.patch"
+ "wpa-supplicant-fix-key-reuse.patch"
+ "wpa-supplicant-fix-zeroed-keys.patch"
+ "wpa-supplicant-fix-nonce-reuse.patch"
+ "wpa-supplicant-krack-followups.patch"))
(sha256
(base32
"0l0l5gz3d5j9bqjsbjlfcv4w4jwndllp9fmyai4x9kg6qhs6v4xl"))))
@@ -2134,7 +2144,7 @@ tool for remote execution and deployment.")
(define-public neofetch
(package
(name "neofetch")
- (version "3.2.0")
+ (version "3.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/dylanaraps/neofetch/"
@@ -2142,10 +2152,10 @@ tool for remote execution and deployment.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "07a32rzmch51znxspzyc7zyaldmr383v70b49wmnjdjs2qfdbv3a"))))
+ "15p69q0jchfms1fpb4i7kq8b28w2xpgh2zmynln618qxv1myf228"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; there are no tests
+ `(#:tests? #f ; there are no tests
#:make-flags
(list (string-append "PREFIX=" %output))
#:phases
@@ -2162,7 +2172,15 @@ tool for remote execution and deployment.")
(("\"/usr/share/neofetch")
(string-append "\"" out "/share/neofetch"))))
#t))
- (delete 'configure))))
+ (delete 'configure) ; no configure script
+ (replace 'install
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version))
+ (etc (string-append doc "/examples/etc")))
+ (zero? (apply system* `("make" ,@make-flags
+ ,(string-append "SYSCONFDIR=" etc)
+ "install")))))))))
(home-page "https://github.com/dylanaraps/neofetch")
(synopsis "System info script")
(description "Neofetch is a CLI system information tool written in Bash.