summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm39
1 files changed, 34 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9636ee939f..11a2d1622b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -100,6 +100,35 @@ usual file attributes can be checked for inconsistencies.")
(home-page "http://aide.sourceforge.net/")
(license license:gpl2+)))
+(define-public progress
+ (package
+ (name "progress")
+ (version "0.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Xfennec/"
+ name "/archive/v" version ".tar.gz"))
+ (sha256
+ (base32 "133iar4vq5vlklydb4cyazjy6slmpbndrws474mg738bd8avc30n"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (arguments
+ `(#:tests? #f ; There is no test suite.
+ #:make-flags (list "CC=gcc" "LDFLAGS+=-lncurses"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; There's no configure phase.
+ (home-page "https://github.com/Xfennec/progress")
+ (synopsis "Program to view the progress of the coreutils commands")
+ (description "A program that looks for coreutils basic commands (cp, mv,
+dd, tar, gzip/gunzip, cat, etc.) currently running on your system and displays
+the percentage of copied data. It can also show estimated time and throughput,
+and provides a \"top-like\" mode (monitoring).")
+ (license license:gpl3+)))
+
(define-public dmd
;; Deprecated. Kept around "just in case."
(let ((base-version "0.2")
@@ -768,7 +797,7 @@ system administrator.")
(sha256
(base32
"0263gi6i19fyzzc488n0qw3m518i39f6a7qmrfvahk9j10bkh5j3"))
- (patches (list (search-patch "sudo-CVE-2015-5602.patch")))))
+ (patches (search-patches "sudo-CVE-2015-5602.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -842,10 +871,10 @@ commands and their arguments.")
(base32
"05mkp5bx1c3z7h5biddsv0p49gkrq9ksany3anp4wdiv92p5prfc"))
(patches
- (map search-patch '("wpa-supplicant-CVE-2015-5310.patch"
- "wpa-supplicant-CVE-2015-5314.patch"
- "wpa-supplicant-CVE-2015-5315.patch"
- "wpa-supplicant-CVE-2015-5316.patch")))))
+ (search-patches "wpa-supplicant-CVE-2015-5310.patch"
+ "wpa-supplicant-CVE-2015-5314.patch"
+ "wpa-supplicant-CVE-2015-5315.patch"
+ "wpa-supplicant-CVE-2015-5316.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-replace