summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm32
1 files changed, 22 insertions, 10 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index 14579e9ea9..54c9116baf 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -45,18 +45,30 @@
'configure 'patch-makefile-SHELL
(lambda _
(patch-makefile-SHELL "include/buildmacros"))
- (alist-replace
- 'check
- (lambda _
- (system* "make" "tests" "-C" "test")
+ ,(if (%current-target-system)
+ '%standard-cross-phases
+ '(alist-replace 'check
+ (lambda _
+ (system* "make" "tests" "-C" "test")
- ;; XXX: Ignore the test result since this is
- ;; dependent on the underlying file system.
- #t)
- %standard-phases))))
+ ;; XXX: Ignore the test result since this is
+ ;; dependent on the underlying file system.
+ #t)
+ %standard-phases)))))
(inputs `(("attr" ,attr)
- ("gettext" ,guix:gettext)
- ("perl" ,perl)))
+
+ ;; Perl is needed to run tests; remove it from cross builds.
+ ,@(if (%current-target-system)
+ '()
+ `(("gettext" ,guix:gettext)
+ ("perl" ,perl)))))
+ (native-inputs
+ ;; FIXME: Upon next core-updates, make gettext a native input
+ ;; unconditionally.
+ (if (%current-target-system)
+ `(("gettext" ,guix:gettext))
+ '()))
+
(home-page
"http://savannah.nongnu.org/projects/acl")
(synopsis