summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 53efa4a684..1e39122483 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,13 @@ AC_ARG_WITH([zsh-completion-dir],
[zshcompletiondir='${datadir}/zsh/site-functions'])
AC_SUBST([zshcompletiondir])
+AC_ARG_WITH([fish-completion-dir],
+ AC_HELP_STRING([--with-fish-completion-dir=DIR],
+ [name of the Fish completion directory]),
+ [fishcompletiondir="$withval"],
+ [fishcompletiondir='${datadir}/fish/vendor_completions.d'])
+AC_SUBST([fishcompletiondir])
+
dnl Better be verbose.
AC_MSG_CHECKING([for the store directory])
AC_MSG_RESULT([$storedir])