summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 4 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index d18e330797..8bae85e144 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,6 +102,7 @@ MODULES = \
guix/build/rpath.scm \
guix/build/cvs.scm \
guix/build/svn.scm \
+ guix/build/syscalls.scm \
guix/build/gremlin.scm \
guix/build/emacs-utils.scm \
guix/build/graft.scm \
@@ -158,13 +159,6 @@ MODULES += \
endif
-if BUILD_SYSCALLS_MODULE
-
-MODULES += \
- guix/build/syscalls.scm
-
-endif
-
if BUILD_DAEMON_OFFLOAD
MODULES += \
@@ -385,13 +379,6 @@ EXTRA_DIST += \
endif !BUILD_DAEMON_OFFLOAD
-if !BUILD_SYSCALLS_MODULE
-
-EXTRA_DIST += \
- guix/build/syscalls.scm
-
-endif !BUILD_SYSCALLS_MODULE
-
CLEANFILES = \
$(GOBJECTS) \
@@ -402,11 +389,13 @@ CLEANFILES = \
# there that are newer than the local .scm files (for instance because the
# user ran 'make install' recently). When that happens, we end up loading
# those previously-installed .go files, which may be stale, thereby breaking
-# the whole thing.
+# the whole thing. Likewise, set 'XDG_CACHE_HOME' to avoid loading possibly
+# stale files from ~/.cache/guile/ccache.
%.go: make-go ; @:
make-go: $(MODULES) guix/config.scm guix/tests.scm
$(AM_V_at)echo "Compiling Scheme modules..." ; \
unset GUILE_LOAD_COMPILED_PATH ; \
+ XDG_CACHE_HOME=/nowhere \
host=$(host) srcdir="$(top_srcdir)" \
$(top_builddir)/pre-inst-env \
$(GUILE) -L "$(top_builddir)" -L "$(top_srcdir)" \