summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6106250b37..7474b7f375 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -553,6 +553,7 @@ EXTRA_DIST += \
build-aux/check-final-inputs-self-contained.scm \
build-aux/compile-as-derivation.scm \
build-aux/generate-authors.scm \
+ build-aux/git-authenticate.scm \
build-aux/test-driver.scm \
build-aux/update-guix-package.scm \
build-aux/update-NEWS.scm \
@@ -615,6 +616,18 @@ $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
install-data-hook:
touch "$(DESTDIR)$(guileobjectdir)/guix/config.go"
+# Commit corresponding to the 'v1.0.1' tag.
+commit_v1_0_1 = d68de958b60426798ed62797ff7c96c327a672ac
+
+# Authenticate the current Git checkout by checking signatures on every commit
+# starting from $(commit_v1_0_1).
+authenticate:
+ $(AM_V_at)echo "Authenticating Git checkout..." ; \
+ "$(top_builddir)/pre-inst-env" $(GUILE) \
+ --no-auto-compile -e git-authenticate \
+ "$(top_srcdir)/build-aux/git-authenticate.scm" \
+ "$(commit_v1_0_1)"
+
# Assuming Guix is already installed and the daemon is up and running, this
# rule builds from $(srcdir), creating and building derivations.
as-derivation:
@@ -865,7 +878,7 @@ cuirass-jobs.scm: $(GOBJECTS)
.PHONY: gen-ChangeLog gen-AUTHORS gen-tarball-version
.PHONY: assert-no-store-file-names assert-binaries-available
.PHONY: assert-final-inputs-self-contained
-.PHONY: clean-go make-go as-derivation
+.PHONY: clean-go make-go as-derivation authenticate
.PHONY: update-guix-package update-NEWS release
# Downloading up-to-date PO files.