summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ada4cbea0b..76d505abf5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,7 +88,6 @@ MODULES = \
guix/build/rpath.scm \
guix/build/cvs.scm \
guix/build/svn.scm \
- guix/build/syscalls.scm \
guix/build/gremlin.scm \
guix/build/emacs-utils.scm \
guix/build/graft.scm \
@@ -124,6 +123,13 @@ MODULES = \
guix.scm \
$(GNU_SYSTEM_MODULES)
+if BUILD_SYSCALLS_MODULE
+
+MODULES += \
+ guix/build/syscalls.scm
+
+endif
+
if BUILD_DAEMON_OFFLOAD
MODULES += \
@@ -298,6 +304,13 @@ EXTRA_DIST += \
endif !BUILD_DAEMON_OFFLOAD
+if !BUILD_SYSCALLS_MODULE
+
+EXTRA_DIST += \
+ guix/build/syscalls.scm
+
+endif !BUILD_SYSCALLS_MODULE
+
CLEANFILES = \
$(GOBJECTS) \