summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6a4cfcd4a1..2b78091af3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -609,7 +609,7 @@ $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
# The above trick doesn't work for 'config.go' because both 'config.scm' and
# 'config.go' are listed in $(nobase_nodist_guileobject_DATA). Thus, give it
# special treatment.
-install-data-hook: set-bootstrap-executable-permissions
+install-data-hook:
touch "$(DESTDIR)$(guileobjectdir)/guix/config.go"
# Assuming Guix is already installed and the daemon is up and running, this
@@ -825,6 +825,7 @@ assert-no-store-file-names:
--exclude=guix-cookbook.pot --exclude=guix-cookbook.*.po \
--exclude=guix-prettify.el \
--exclude=ChangeLog* \
+ --exclude=binutils-boot-2.20*.patch \
-E "$(storedir)/[a-z0-9]{32}-" $(distdir) ; \
then \
echo "error: store file names embedded in the distribution" >&2 ; \