summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm3
-rw-r--r--gnu/packages/rdf.scm6
2 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e15381b68a..e607d1a9a0 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -208,8 +209,6 @@ namespace ARDOUR { const char* revision = \"3.5-403-gec2cb31\" ; }"))))
("sratom" ,sratom)
("suil" ,suil)
("lilv" ,lilv)
- ("rasqal" ,rasqal)
- ("raptor2" ,raptor2)
("redland" ,redland)
("rubberband" ,rubberband)
("taglib" ,taglib)
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index f26b021e50..cee7f42398 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -221,9 +221,10 @@ Turtle/N3 and read them in SPARQL XML, RDF/XML and Turtle/N3.")
(native-inputs
`(("perl" ,perl) ; needed for installation
("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("rasqal" ,rasqal))) ; in Requires.private field of .pc
(inputs
- `(("bdb" ,bdb)
- ("rasqal" ,rasqal)))
+ `(("bdb" ,bdb)))
(home-page "http://librdf.org/")
(synopsis "RDF library")
(description "The Redland RDF Library (librdf) provides the RDF API
@@ -317,7 +318,6 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(inputs
`(("clucene" ,clucene)
("qt" ,qt-4)
- ("rasqal" ,rasqal)
("redland" ,redland)))
(home-page "http://soprano.sourceforge.net/")
(synopsis "RDF data library for Qt")