summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/lxqt.scm58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index addb6e1217..4931b705db 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -183,6 +183,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/lsh.scm \
gnu/packages/lsof.scm \
gnu/packages/lua.scm \
+ gnu/packages/lxqt.scm \
gnu/packages/lynx.scm \
gnu/packages/m4.scm \
gnu/packages/man.scm \
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
new file mode 100644
index 0000000000..cb6cb64e0b
--- /dev/null
+++ b/gnu/packages/lxqt.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages lxqt)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:select (lgpl2.1+))
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (guix build-system cmake)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages qt))
+
+(define-public libqtxdg
+ (package
+ (name "libqtxdg")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/lxde/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "00j0zzb8zn714lv77fawahlalxjznvh06nlhlz47qf0krngri42w"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; handled by configure flag instead
+ #:configure-flags '(;; FIXME: Currently, the tests fail; this is a
+ ;; known issue, see
+ ;; https://github.com/lxde/libqtxdg/issues/42
+ ;; Enable in new release.
+ "-DBUILD_TESTS=OFF")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("qt" ,qt))) ; according to Qt5Xdg.pc
+ (home-page "https://github.com/lxde/libqtxdg")
+ (synopsis "Qt implementation of freedesktop.org xdg specifications")
+ (description "Libqtxdg implements the freedesktop.org xdg specifications
+in Qt.")
+ (license lgpl2.1+)))