summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/gtk.scm41
-rw-r--r--gnu/packages/patches/pango-skip-libthai-test.patch23
4 files changed, 61 insertions, 8 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7462445c98..62561c7261 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1242,6 +1242,7 @@ dist_patch_DATA = \
%D%/packages/patches/p7zip-CVE-2017-17969.patch \
%D%/packages/patches/p7zip-remove-unused-code.patch \
%D%/packages/patches/pam-mount-luks2-support.patch \
+ %D%/packages/patches/pango-skip-libthai-test.patch \
%D%/packages/patches/patchutils-test-perms.patch \
%D%/packages/patches/patch-hurd-path-max.patch \
%D%/packages/patches/pcre2-fix-jit_match-crash.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 37873e42bc..d492739df5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1543,7 +1543,9 @@ dealing with different structured file formats.")
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(inputs
- `(("pango" ,pango)
+ `(;; XXX: 1.44 causes some test failures, so we stick with 1.42 for
+ ;; this ancient version of librsvg.
+ ("pango" ,pango-1.42)
("libcroco" ,libcroco)
("bzip2" ,bzip2)
("libgsf" ,libgsf)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 67b129c2a1..0ab5c36ca1 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -222,16 +222,28 @@ affine transformation (scale, rotation, shear, etc.).")
(define-public pango
(package
(name "pango")
- (version "1.42.4")
+ (version "1.44.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/pango/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
+ (patches (search-patches "pango-skip-libthai-test.patch"))
(sha256
(base32
- "17bwb7dgbncrfsmchlib03k9n3xaalirb39g3yb43gg8cg6p8aqx"))))
- (build-system gnu-build-system)
+ "07qvxa2sk90chp1l12han6vxvy098mc37sdqcznyywyv2g6bd9b6"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-cantarell-tests
+ (lambda _
+ (substitute* "tests/meson.build"
+ ;; XXX FIXME: These tests require "font-cantarell", but
+ ;; adding it here would introduce a circular dependency.
+ (("\\[ 'test-harfbuzz'.*") "")
+ (("\\[ 'test-itemize'.*") "")
+ (("\\[ 'test-layout'.*") ""))
+ #t)))))
(propagated-inputs
;; These are all in Requires or Requires.private of the '.pc' files.
`(("cairo" ,cairo)
@@ -239,13 +251,13 @@ affine transformation (scale, rotation, shear, etc.).")
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("glib" ,glib)
- ("harfbuzz" ,harfbuzz)))
- (inputs
- `(("zlib" ,zlib)
+ ("harfbuzz" ,harfbuzz)
;; Some packages, such as Openbox, expect Pango to be built with the
;; optional libxft support.
("libxft" ,libxft)))
+ (inputs
+ `(("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.
@@ -258,6 +270,21 @@ used throughout the world.")
(license license:lgpl2.0+)
(home-page "https://developer.gnome.org/pango/")))
+(define-public pango-1.42
+ (package/inherit
+ pango
+ (version "1.42.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/pango/"
+ (version-major+minor version) "/"
+ "pango-" version ".tar.xz"))
+ (sha256
+ (base32
+ "17bwb7dgbncrfsmchlib03k9n3xaalirb39g3yb43gg8cg6p8aqx"))))
+ (build-system gnu-build-system)
+ (arguments '())))
+
(define-public pangox-compat
(package
(name "pangox-compat")
diff --git a/gnu/packages/patches/pango-skip-libthai-test.patch b/gnu/packages/patches/pango-skip-libthai-test.patch
new file mode 100644
index 0000000000..98732b5391
--- /dev/null
+++ b/gnu/packages/patches/pango-skip-libthai-test.patch
@@ -0,0 +1,23 @@
+Skip Thai character test when libthai is unavailable.
+
+Taken from upstream bug tracker:
+https://gitlab.gnome.org/GNOME/pango/merge_requests/161
+https://gitlab.gnome.org/GNOME/pango/commit/b73284747ac937e31dc9191f84ed6e24284c88ee
+
+diff --git a/tests/test-break.c b/tests/test-break.c
+index 8549b678bba69360d07dce3af21d915412f20d51..47fa3009165e19a331aa04a0df4351ae2323933b 100644
+--- a/tests/test-break.c
++++ b/tests/test-break.c
+@@ -305,6 +305,12 @@ main (int argc, char *argv[])
+ if (!strstr (name, "break"))
+ continue;
+
++#ifndef HAVE_LIBTHAI
++ /* four.break involves Thai, so only test it when we have libthai */
++ if (strstr (name, "four.break"))
++ continue;
++#endif
++
+ path = g_strdup_printf ("/break/%s", name);
+ g_test_add_data_func_full (path, g_test_build_filename (G_TEST_DIST, "breaks", name, NULL),
+ test_break, g_free);