summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c0cb4ae7fd..6619142b50 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1962,7 +1962,15 @@ backported from Python 2.7 for Python 2.4+.")
("python-parse" ,python-parse)
("python-parse-type" ,python-parse-type)))
(arguments
- '(#:test-target "behave_test"))
+ '(#:test-target "behave_test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-library-loading
+ (lambda _
+ ;; Otherwise, tests fail with no module named 'path'
+ (setenv "PYTHONPATH" (string-append (getenv "PYTHONPATH") ":"
+ (getcwd) "/tasks/_vendor"))
+ #t)))))
(home-page "https://github.com/behave/behave")
(synopsis "Python behavior-driven development")
(description