summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-crypto.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 29e0ee5951..6ca82cb061 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1016,3 +1016,23 @@ relevant RFCs too.")
(description "This package provides a Python implementation of the HMAC Key
Derivation function (HKDF) defined in RFC 5869.")
(license license:bsd-2)))
+
+(define-public python-spake2
+ (package
+ (name "python-spake2")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "spake2" version))
+ (sha256
+ (base32
+ "1x16r7lrbklvfzbacb66qv9iiih6liq1y612dqh2chgf555n2yn1"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-hkdf" ,python-hkdf)))
+ (home-page "https://github.com/warner/python-spake2")
+ (synopsis "SPAKE2 password-authenticated key exchange in Python")
+ (description "This package provides a Python implementation of the SPAKE2
+Password-Authenticated Key Exchange algorithm.")
+ (license license:expat)))