summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/finance.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 823eabf5a8..9e346a6625 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -70,7 +70,8 @@
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python) ; for the tests
- ("util-linux" ,util-linux))) ; provides the hexdump command for tests
+ ("util-linux" ,util-linux) ; provides the hexdump command for tests
+ ("qttools" ,qttools)))
(inputs
`(("bdb" ,bdb-5.3) ; with 6.2.23, there is an error: ambiguous overload
("boost" ,boost)
@@ -78,8 +79,7 @@
("miniupnpc" ,miniupnpc)
("openssl" ,openssl)
("protobuf" ,protobuf)
- ;; TODO Build with the modular Qt.
- ("qt" ,qt)))
+ ("qtbase" ,qtbase)))
(arguments
`(#:configure-flags
(list
@@ -87,7 +87,16 @@
"--with-incompatible-bdb"
;; Boost is not found unless specified manually.
(string-append "--with-boost="
- (assoc-ref %build-inputs "boost")))
+ (assoc-ref %build-inputs "boost"))
+ ;; XXX: The configure script looks up Qt paths by
+ ;; `pkg-config --variable=host_bins Qt5Core`, which fails to pick
+ ;; up executables residing in 'qttools', so we specify them here.
+ (string-append "ac_cv_path_LRELEASE="
+ (assoc-ref %build-inputs "qttools")
+ "/bin/lrelease")
+ (string-append "ac_cv_path_LUPDATE="
+ (assoc-ref %build-inputs "qttools")
+ "/bin/lupdate"))
#:phases
(modify-phases %standard-phases
(add-before 'check 'set-home