summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/pcre2-fix-jit_match-crash.patch25
-rw-r--r--gnu/packages/pcre.scm5
3 files changed, 2 insertions, 29 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 21102514a9..b1b5045469 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1222,7 +1222,6 @@ dist_patch_DATA = \
%D%/packages/patches/pam-mount-luks2-support.patch \
%D%/packages/patches/patchutils-test-perms.patch \
%D%/packages/patches/patch-hurd-path-max.patch \
- %D%/packages/patches/pcre2-fix-jit_match-crash.patch \
%D%/packages/patches/perl-autosplit-default-time.patch \
%D%/packages/patches/perl-deterministic-ordering.patch \
%D%/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
diff --git a/gnu/packages/patches/pcre2-fix-jit_match-crash.patch b/gnu/packages/patches/pcre2-fix-jit_match-crash.patch
deleted file mode 100644
index 7543319ee9..0000000000
--- a/gnu/packages/patches/pcre2-fix-jit_match-crash.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Thu, 01 Aug 2019 21:12:52 +0200
-Subject: [PATCH] gnu: pcre2: Fix jit_match crash.
-
-Fixes <https://bugs.exim.org/show_bug.cgi?id=2421>, reported as a ‘secrity
-problem’.
-
-Copied verbatim from upstream[0].
-
-[0]: https://vcs.pcre.org/pcre2/code/trunk/src/pcre2_jit_compile.c?view=patch&r1=1089&r2=1092&pathrev=1092
-
---- trunk/src/pcre2_jit_compile.c 2019/05/10 13:15:20 1089
-+++ trunk/src/pcre2_jit_compile.c 2019/05/13 16:38:18 1092
-@@ -8571,7 +8571,10 @@
- PCRE2_SPTR bptr;
- uint32_t c;
-
--GETCHARINC(c, cc);
-+/* Patch by PH */
-+/* GETCHARINC(c, cc); */
-+
-+c = *cc++;
- #if PCRE2_CODE_UNIT_WIDTH == 32
- if (c >= 0x110000)
- return NULL;
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 91c32d6e5d..560244619e 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -89,15 +89,14 @@ POSIX regular expression API.")
(define-public pcre2
(package
(name "pcre2")
- (version "10.33")
+ (version "10.34")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/pcre/pcre2/"
version "/pcre2-" version ".tar.bz2"))
- (patches (search-patches "pcre2-fix-jit_match-crash.patch"))
(sha256
(base32
- "1anqi7vpbfzag7imccrc6di1zl5rl63ab7rfpmajpw6d1kzlsl9m"))))
+ "1jlqnzcz2yi70dm40wyfa9w8is9z2kh4dl8zjnv3vqd9mgzp7i3l"))))
(build-system gnu-build-system)
(inputs `(("bzip2" ,bzip2)
("readline" ,readline)