summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xorg.scm9
-rw-r--r--gnu/system.scm3
2 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index f3d415c096..c2023dead2 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5300,6 +5300,15 @@ draggable titlebars and borders.")
("xproto" ,xproto)))
(native-inputs
`(("pkg-config" ,pkg-config)))
+;; TODO: add XCURSOR_PATH=.../share/icons to profile search paths, so
+;; libXcursor finds cursors installed into a profile. If we solve bugs
+;; <http://bugs.gnu.org/20255> and <http://bugs.gnu.org/22138>, we can fix
+;; this with a search-path as follows:
+;;
+;; (native-search-paths
+;; (list (search-path-specification
+;; (variable "XCURSOR_PATH")
+;; (files '("share/icons")))))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg Cursor management library")
(description "Xorg Cursor management library.")
diff --git a/gnu/system.scm b/gnu/system.scm
index 0e834ba5ed..5f562b48bb 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -583,6 +583,9 @@ export INFOPATH=$HOME/.guix-profile/share/info:/run/current-system/profile/share
export XDG_DATA_DIRS=$HOME/.guix-profile/share:/run/current-system/profile/share
export XDG_CONFIG_DIRS=$HOME/.guix-profile/etc/xdg:/run/current-system/profile/etc/xdg
+# Make sure libXcursor finds cursors installed into user or system profiles. See <http://bugs.gnu.org/24445>
+export XCURSOR_PATH=$HOME/.icons:$HOME/.guix-profile/share/icons:/run/current-system/profile/share/icons
+
# Ignore the default value of 'PATH'.
unset PATH